Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! - View Profile: NAJ

     


NAJ NAJ is offline

Just A Guy

  Feedback

Member Profile Recent Ratings
Feedback Score:
Positive Feedback:
25
100.0%
Members who left positive:
Members who left negative:
25
0
Total positive feedback: 26
Submit Feedback
  Past
Month
Past
6 Months
Past
12 Months
Positive Positive 0 0 0
Neutral Neutral 0 0 0
Negative Negative 0 0 0

  Visitor Messages

Showing Visitor Messages 1 to 10 of 35
  1. DCTZ
    11-15-2016 09:58 AM - permalink
    DCTZ
    I see you are in NJ. I am in NNE NJ at the NY boarder and an original owner of a 85 Turbo Z. Just got it back on the road after its hibernation in the garage. I have been active with Turbo Dodge on and off for 25+ years. Message me back.

    DCTZ
  2. gakeanh
  3. gema
    09-21-2013 11:16 AM - permalink
    gema
    Naj, looking for advice. My 1986 Daytona rear bumper support and energy absorber posts need replacing but I can't find anywhere. Can you help me as to what I can do or where I can search. Thanks Gema
  4. DWILLIS
    07-24-2012 10:50 AM - permalink
    DWILLIS
    Hey NAJ, could you pm me the differencs between a t1 and a t2 head? thanks, my friend is offering me a head off his 89 shadow with the turbo and everything for $20, just wanna make sure im making the right devision, Thanks man!
  5. EL PROFETA12
    04-28-2012 05:35 PM - permalink
    EL PROFETA12
    hi good day, I'm from mexico, and I have a dodge daytona shelby 90, I have a problem with the MAP sensor is the same as you in the picture, which is the price you have your sensor as well as shipping to Mexico to zip 37530
  6. EL PROFETA12
    04-28-2012 05:32 PM - permalink
    EL PROFETA12
    hola buen dia, oie disculpa soy de mexico, y tengo un shelby dodge daytona 90, tengo un problema con el sensor MAP es el mismo que tienes en la fotografia; cual es el precio que tiene tu sensor, asi como el envio a mexico al zip 37530
  7. mopar76
    03-06-2012 12:29 AM - permalink
    mopar76
    hey do you have the pinout for a 93 3.0 l 5 speed? thanks
  8. waegele
    12-26-2011 04:04 PM - permalink
    waegele
    Thank you for all your help. I just saw on your profile that you are from jersey & go to atco speedway. this was stomping grounds of mine 20-30 years ago (west deptford high). It been a while but the memories flooded back when I saw you had it listed. Thanks so much for your help. it made the impossible, possible. I posted some positive feedback for you, just cant thank you enough.
  9. 1985shelbyturbo
    11-27-2011 10:40 AM - permalink
    1985shelbyturbo
    im having problems with my 1985 shelby charger 2.2 turbo,it runs very rich and many vacuum lines have been messed up and rerouted incorrectly,ive got some of the vaccum lines fixed to what i think are correct but i am sure plenty of them are still incorrect i dont know much about this car i think its the map sensor and/or the o2 sensor,the car also has a high performance holley throttle body could this bee my problem? if it helps telling you this my boost guage dont work either. please help!
  10. turismolover22
    08-13-2010 07:41 PM - permalink
    turismolover22
    Congrats on the SuperMod bumpage!

  About Me

  • About NAJ
    First Name
    Jan
    Location
    New Jersey
    Occupation
    Commercial Sales Manager, Autozone
  • My Ride
    Ride
    1990 Daytona Shelby
    Engine type and displacement
    2.2 L VNT
    Induction
    Turbo
    Major modifications
    None
    Tranny type
    Manual
    Tires
    Street Radials
    Race weight
    3196
    Horsepower
    174
    60 foot time
    2.230
    1/8 Mile ET
    9.940
    1/8 Mile MPH
    68.43
    1/4 Mile ET
    15.570
    1/4 Mile MPH
    87.90
    Density Altitude
    Sea Lev
    Track Name
    Atco Raceway
  • Signature
    Jan
    1990 Daytona Shelby VNT

    37 Years ASE Certified

  Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Last Activity: Today 06:38 AM
  • Join Date: 03-13-2007

  Friends

Showing Friends 1 to 10 of 48

  Mentions

06-21-2016
06:17 PM - Wildwest mentioned NAJ in post Re: MSD Ignition Issue
NAJ I'm afraid you've mi...

  Quotes

12-05-2016
09:31 AM - ILIKESHELBYS quoted NAJ in post Re: Code 54 Fuel Sync signal loss
Rent a fuel pressure gau...
11-28-2016
04:38 PM - jimmytroy quoted NAJ in post Re: Anyone: torque specs for sway bar bushings?
Probably a little late b...
11-21-2016
03:11 PM - LaserDad quoted NAJ in post Re: Engine Temp Sensor for Temp Gauge
The sending unit for the...
07:03 AM - LaserDad quoted NAJ in post Re: Engine Temp Sensor for Temp Gauge
There are two different ...
11-19-2016
07:01 PM - LaserDad quoted NAJ in post Re: Engine Temp Sensor for Temp Gauge
If the temp gauge reads ...
11-18-2016
01:22 PM - NAJ quoted N/aNate in post Re: Dodge shadow no start please help!
This is on a 93 no red and w...
11-15-2016
07:58 PM - donniegilbert quoted NAJ in post Re: 1987 Shelby Charger T1 not running properly
A cold engine requires m...
11-14-2016
08:57 PM - abgwin quoted NAJ in post Re: Rapid turn signal, but all bulbs are good
You have two separate fl...
08:05 AM - NAJ quoted Shane in post Re: Help please 87 caravan 3.0 wont go past 1/4 throttle
Naj I wanna thank you so m...
06:49 AM - NAJ quoted helpful_hw_man in post Re: '87 Shelby CSX: electric fan got sticky, now overheating
I'm further along in diagnostics. ...
11-13-2016
08:37 PM - donniegilbert quoted NAJ in post Re: 1987 Shelby Charger T1 not running properly
1)GROUND CIRCUITS Reall...
11-10-2016
09:20 AM - NAJ quoted donniegilbert in post Re: Member naj
He's been a BIG help on my project...
11-09-2016
08:50 PM - donniegilbert quoted NAJ in post Re: 1987 Shelby Charger T1 not running properly
I re-read the entire thr...
07:27 PM - NAJ quoted Beastly in post Re: help identify open wire connections 2.5 turbo
As for the parasitic drain ...
06:21 PM - NAJ quoted GLH_Turbo22 in post Re: 1987 Shelby Charger T1 not running properly
I only say its a dumb question c...
08:50 AM - donniegilbert quoted NAJ in post Re: 1987 Shelby Charger T1 not running properly
1)Did you verify the cod...
11-08-2016
07:50 PM - donniegilbert quoted NAJ in post Re: 1987 Shelby Charger T1 not running properly
Your TPS voltages are ba...
06:26 AM - NAJ quoted Tiredjadedsoul in post Re: Torque steer from hell
1)Other clue ... when I turn hard t...
11-05-2016
01:21 PM - donniegilbert quoted NAJ in post Re: 1987 Shelby Charger T1 not running properly
You need to clear the co...
12:40 PM - jenkins71 quoted NAJ in post Re: 2.5 turbo running rich at idle
You need to verify that ...
 
For the best viewing experience please update your browser to Google Chrome