Car Won't start....... Smoke! - Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more!
TurboDodge.com MarketPlace Shelby Registry Contact Us

Advertisement - Remove these ads today by clicking here.
Go Back   Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! > Turbo specific > Turbo III

Turbo III Help with turbo III cars

Reply
 
LinkBack Thread Tools
Old 05-28-2008, 10:39 PM   #1
Car Won't start....... Smoke!  
TD New Guy
 
Join Date: Feb 2006
Location: North Carolina

My Ride: Dodge Spirit R/T
Induct: Turbo
1/4: 0.000

Posts: 134
Feedback: (0)
tazaroo is keeping the peace
My car has been driving great for the last 3k or so but not today. When I tried to start it, the motor turned and cranked for a second and then cut off and I immediately saw white smoke come out from under the hood. I tried to crank it again and the motor turned, would not start and I saw more white smoke come bellowing out form the hood. I smelt an awful burning smell like wires or rubber. The smoke went away within 15 second or so after I quit trying to start the car. I raised the hood and I could smell where wires or something had burned somewhere near the battery, computer, throttle body area where a lot of wiring is. I could not see anything upon quick inspection but I'm no mechanic. I waited a few more minutes and tried to crank one more time and same thing happened, engine turned no crank and smoke. I did not dare try again. The check engine light was giving me a code of 12 which says something about battery power and wiring.

Any thoughts to what might have happend? Thanks
tazaroo is offline  
Reply With Quote Quick reply to this message Share on facebook
Sponsored Links
Advertisement
 
Old 05-28-2008, 10:42 PM   #2
Re: Car Won't start....... Smoke!  
TD Extreme User!
 
Join Date: Sep 2004
Location: garfield, NJ

My Ride: TIII R/T
Engine: 2.2L TURBO III
Induct: Turbo
1/4: 13.743

Posts: 9,066
Feedback: (23)
Images: 5
xtrempickup is keeping our cars running
check all your wiring, check the O2 wiring also, normal problem with them, they melt and ground out and then you get a no start because they run near the turbo. check that first then anyplace that looks suspicious
xtrempickup is offline  
Reply With Quote Quick reply to this message
Old 05-29-2008, 08:40 AM   #3
Re: Car Won't start....... Smoke!  
Boostaholic
 
Join Date: Nov 2004
Location: Baltimore,MD

My Ride: 91 Spirit R/T,
Engine: 2.2 TIII
Induct: Turbo
1/4: 14.800

Posts: 973
Feedback: (6)
rx2mazda is keeping the peace
Just had that o2 thing happen to me =) No smoke though just popped the FL to the ASD.

does it smoke when you turn the key to "on" or just when you try to start it? Check for a short around the starter and battery. you could also have a corroded ground with very high resistance. Good luck
rx2mazda is offline  
Reply With Quote Quick reply to this message
Old 05-29-2008, 05:43 PM   #4
Re: Car Won't start....... Smoke!  
TD New Guy
 
Join Date: Feb 2006
Location: North Carolina

My Ride: Dodge Spirit R/T
Induct: Turbo
1/4: 0.000

Posts: 134
Feedback: (0)
tazaroo is keeping the peace
Quote:
Originally Posted by rx2mazda View Post
Just had that o2 thing happen to me =) No smoke though just popped the FL to the ASD.

does it smoke when you turn the key to "on" or just when you try to start it? Check for a short around the starter and battery. you could also have a corroded ground with very high resistance. Good luck
thanks,

It seems to smoke when the engine is turning, not when it is on the on position. Hopefully I didn't fry something expensive or a hard to find part. I did hear something the other day after driving. I rose the hood and it sounded almost like a very light sizzling sound or like air leak sound coming from the battery I think. It was very light and stopped after the car cooled down several minutes. I didn't worry too much about it at the time.
tazaroo is offline  
Reply With Quote Quick reply to this message
Old 05-31-2008, 07:32 PM   #5
Re: Car Won't start....... Smoke!  
Garrett Booster
 
Join Date: May 2008
Location: glenside

My Ride: 88shelby,90daytonaes
Engine: 2.2 intercooled turbo, 3.0 sohc v-6
1/4: 0.000

Posts: 188
Feedback: (1)
mmtphoto is keeping the peace
this has to have something to do with your starter-follow the positive wire and see if insulation is missing somewhere-although I'd have to think that there would be some kind of fuse or fusible link that would avoid the drama of smoke:ee

You need to get someone to crank it while you look, and I wouldn't go crazy-short cranks, have a voltage meter close so you can check out the voltage to the alternator (rear post) and the battery posts, especially when cranking-if the voltage is dropping radically (under 9 volts) when cranking, you have a short that needs to be fixed or it'll be real expensive. good luck
mmtphoto is offline  
Reply With Quote Quick reply to this message
Old 06-01-2008, 04:41 AM   #6
Re: Car Won't start....... Smoke!  
TD Extreme User!
 
Join Date: Jun 2003
Location: Salina, KS

My Ride: 91 Spirit R/T
Engine: 2.2 TIII
Induct: Turbo
1/4: 11.686

Posts: 5,078
Feedback: (6)
Images: 5
mopar2ya is keeping our cars runningmopar2ya is keeping our cars running
I agree with a starter wire. Its only activated in the start position on the switch. If it makes the problem with the key on it can be else where but start tends to narrow it to the starter with or solenoid wire. It may have shorted out.
mopar2ya is offline  
Reply With Quote Quick reply to this message
Old 06-02-2008, 02:15 PM   #7
Re: Car Won't start....... Smoke!  
TD Extreme User!
 
Join Date: Jan 2003
Location: Gillette, Wyoming

My Ride: Dodge Spirit R/T
Engine: 2.2L Turbo III
Induct: Turbo
1/4: 0.000

Posts: 4,694
Feedback: (2)
iTurbo has really helped outiTurbo has really helped out
I'm guessing it's probably a toasted fuse link. When they go, they get hot and melt the insulation and wire and open the circuit. This causes the smoke. Probably the fuse link for the ASD relay since it happened as you were attempting to start the car.

If your car has the Power Distribution Center (big black box on driver side strut tower), then it won't have fuse links and the burnt wiring could be just about anything, but I would also check the wiring for the starter.
iTurbo is offline  
Reply With Quote Quick reply to this message
Old 06-13-2008, 11:00 PM   #8
Re: Car Won't start....... Smoke!  
TD New Guy
 
Join Date: Feb 2006
Location: North Carolina

My Ride: Dodge Spirit R/T
Induct: Turbo
1/4: 0.000

Posts: 134
Feedback: (0)
tazaroo is keeping the peace
Thanks guys, the car is running great again. :) It was the starter wire shorting out and I was blowing a switch as well. The o2 wires were also fried. Unfortunately it took alot of diagnosing to find all the bad wires. I had to take it to the shop. I took it to Darrell Cox Racing since they are only an hour from me. I think they did a great job but the diagnostics did add up some. I also had them fix an oil leak and a few other things while it was there. They usually work on SRT4's but they were glad to work on my car. I must say they told me they were impressed how the car drove and how quick it was for a stock turbo. I eventually want to change that but I am trying to get the bugs out first to have a reliable fast car.
tazaroo is offline  
Reply With Quote Quick reply to this message
Old 06-13-2008, 11:20 PM   #9
Re: Car Won't start....... Smoke!  
Garrett Booster
 
Join Date: May 2008
Location: glenside

My Ride: 88shelby,90daytonaes
Engine: 2.2 intercooled turbo, 3.0 sohc v-6
1/4: 0.000

Posts: 188
Feedback: (1)
mmtphoto is keeping the peace
starter wire...obvious, and dangerous if left that way, good that you went slow and got it fixed-I can not imagine using my shelby z as a daily driver, so if something is not right, I park it until I can figure it out. I know lots out there use these as DD'ers, but I cannot imagine having to depend on a 20 year old turbo to get back and forth-nice outcome.
mmtphoto is offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2

All times are GMT -5. The time now is 04:26 AM.