no start, help! - Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more!
Turbo III Help with turbo III cars

Reply
 
LinkBack Thread Tools
post #1 of 35 Old 10-26-2012, 04:21 PM
Daytona Junkie
Guest
 
 

Posts: n/a
no start, help!

ok. car wouldnt start at all, not even a click so i replaced the starter. its still not cranking at all. the fuel pump kicks on, not that it matters. its like starting the car with the battery unplugged. i get nothing. battery is fully charged, in fact its brand new. this problem started the end of may. there was no heat shield on the starter so i assumed it was dead. i hear something clicking under the hood every time i turn the key. sounds like a relay. i had a spare and swapped it in and it didnt change. i know for a fact the clicking is not the starter. what could it be? TIA
Sponsored Links
Advertisement
 
post #2 of 35 Old 10-26-2012, 05:02 PM
Garrett Booster
 
Join Date: Feb 2009
Location: pottsville, pa
 
My Ride: 93 iroc rt 93 iroc
Engine: 2.2 turbo III, 3.0 V6
1/4: 0.000

Posts: 210
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: no start, help!

Sounds like you might have a bad ground. Check them all, make sure they are clean and tight. A bad ground can cause all kinds of problems.
zippy93rt is offline  
post #3 of 35 Old 10-26-2012, 05:23 PM
Daytona Junkie
Guest
 
 

Posts: n/a
Re: no start, help!

ill give it a whirl. thanks!
post #4 of 35 Old 10-26-2012, 07:02 PM
Garrett Booster
 
Join Date: Feb 2009
Location: pottsville, pa
 
My Ride: 93 iroc rt 93 iroc
Engine: 2.2 turbo III, 3.0 V6
1/4: 0.000

Posts: 210
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: no start, help!

No problem! Also check your battery terminals, where there wire goes into the lead terminal. They corrode inside, causing a voltage drop. Everything in the car may work but when you hit the key you get nothing. One more thing to check is your ignition lock cylinder, they break inside and wont give you start only acc and run. If it feels weird when turned all the way to start it may be broken.
zippy93rt is offline  
post #5 of 35 Old 10-27-2012, 10:06 PM
Daytona Junkie
Guest
 
 

Posts: n/a
Re: no start, help!

im gonna play around when the rain stops. gotta work from 1AM to7AM tonight so i may end up sleeping all day LOL


key feels fine when i try it. nothing out of the ordinary. hope to start on it soon. its getting cold out :(
post #6 of 35 Old 10-28-2012, 01:27 AM
Meow!!


 
Turbomini's Avatar
 
Join Date: Mar 2007
Location: OH
 
My Ride: 87shelby charger
Engine: 2.2L TII
Induct: Turbo
1/4: 0.000

Posts: 16,420
Images: 217
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: no start, help!

look at the small wire on the relay it might be bad or have a bad connection,
Turbomini is offline  
post #7 of 35 Old 10-28-2012, 02:03 PM
Daytona Junkie
Guest
 
 

Posts: n/a
Re: no start, help!

what wires?
post #8 of 35 Old 10-28-2012, 11:31 PM
TryHard Status


 
turismolover22's Avatar
 
Join Date: Nov 2009
Location: Indiana
 
My Ride: 1986 Daytona Turbo Z
Engine: 2.2 TII
Induct: Turbo
1/4: 0.000

Posts: 10,048
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: no start, help!

Do you have any codes?
turismolover22 is offline  
post #9 of 35 Old 10-29-2012, 01:31 AM
Meow!!


 
Turbomini's Avatar
 
Join Date: Mar 2007
Location: OH
 
My Ride: 87shelby charger
Engine: 2.2L TII
Induct: Turbo
1/4: 0.000

Posts: 16,420
Images: 217
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: no start, help!

for the love of gowd lol there are 2 wires on your starter the big one, and the small one.......make sure its getting power.... lol
Turbomini is offline  
post #10 of 35 Old 10-29-2012, 01:49 PM
Daytona Junkie
Guest
 
 

Posts: n/a
Re: no start, help!

oh, thought you were talking about the relay LOL you must have meant the solenoid


Quote:
Originally Posted by Turbomini View Post
look at the small wire on the relay it might be bad or have a bad connection,


Quote:
Originally Posted by turismolover22 View Post
Do you have any codes?
no codes, though i should check again
post #11 of 35 Old 10-29-2012, 02:06 PM
Meow!!


 
Turbomini's Avatar
 
Join Date: Mar 2007
Location: OH
 
My Ride: 87shelby charger
Engine: 2.2L TII
Induct: Turbo
1/4: 0.000

Posts: 16,420
Images: 217
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: no start, help!

oh dear your gonna have to follow the wire threw the connectors
Turbomini is offline  
post #12 of 35 Old 10-29-2012, 05:05 PM
Daytona Junkie
Guest
 
 

Posts: n/a
Re: no start, help!

i have another harness for it, just really dont feel like taking the starter off again :(
post #13 of 35 Old 10-31-2012, 02:42 PM
Meow!!


 
Turbomini's Avatar
 
Join Date: Mar 2007
Location: OH
 
My Ride: 87shelby charger
Engine: 2.2L TII
Induct: Turbo
1/4: 0.000

Posts: 16,420
Images: 217
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: no start, help!

you dont have to if your actually gonna try to fix it look at the starter relay and make sure its good, then look at the starter harness plug where it goes to the main harness, then make sure thats good if it all checks out then bad starter and if you really wanna go all the way get a volt meter and test to see if the SMALL wire to the relay to starter is good,
Turbomini is offline  
post #14 of 35 Old 10-31-2012, 02:49 PM
Boostaholic
 
Join Date: Apr 2011
Location: Texas
 
Induct: N/A
1/4: 0.000

Posts: 640
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: no start, help!

u have a heat shield around your starter solenoid? i didnt and i burned up the starter contacts,,check them as well.
GhostDaytona is offline  
post #15 of 35 Old 10-31-2012, 04:05 PM
Daytona Junkie
Guest
 
 

Posts: n/a
Re: no start, help!

no, i didnt have one. thought i fried the starter due to not having one and bought a new starter with a heat shield
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome