Weird Electrical / RPM issue... - Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more!

Turbo Dodge Help Urgent help when something goes wrong with your Dodge and you can't figure out what the problem is. Troubleshooting help and the place to post when you're stuck with a broken car and have to get to work the next day.

 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 29 Old 02-14-2017, 05:59 PM Thread Starter
Level 2 Supporter
 
MarkassBauer's Avatar
 
Join Date: Jun 2010
Location: Clinton Township, MI 48036
 
My Ride: 92 Spirit
Engine: 2.2 MPFI
Induct: N/A
1/4: 0.000

Posts: 875
Thanks: 0
Thanked 0 Times in 0 Posts
 
Weird Electrical / RPM issue...

Ok so old ladies car, '93 Spirit 2.5 auto flex fuel. When you turn on headlights or blower motor engine bogs for just a second, when cooling fan turns on car bogs down BIG TIME and once in a while RPMs won't pick back up till fan turns off?.. At first I instantly assumed bad ground! Being that the car has a new battery and alternator. So I went ahead and ran "the big 4" something us 80's-90's guys would do when hooking up a boom box car stereo, you run all 2ga or bigger power wire from the battery to the alternator, a ground to the body of alternator, and body & engine grounds to battery. This did not fix the issue :( The ONLY other electrical issue this car has is randomly a while back the dome light stopped working, and after testing it, it's because it lost its ground... can't turn it on with headlight switch nor opening any door, and if I just grounded it of course it would stay on all the time. I have no idea if these 2 issues coincide or not but EVERYTHING else about the car is absolutely perfect. Thanks for any help guys, cuz I am stumped!

I'd like to add when car surges or bogs down, doesn't seem to dim lights or affect anything but the engine speed... and once in a while when starting the car the air bag light will come on, and sometimes stay on while driving... again thank you for any help or suggestions!
MarkassBauer is offline  
Sponsored Links
Advertisement
 
post #2 of 29 Old 02-14-2017, 06:16 PM
NAJ
Just A Guy


 
NAJ's Avatar
 
Join Date: Mar 2007
Location: New Jersey
 
My Ride: 1990 Daytona Shelby
Engine: 2.2 L VNT
Induct: Turbo
1/4: 15.570

Posts: 22,437
Thanks: 0
Thanked 1 Time in 1 Post
     
Re: Weird Electrical / RPM issue...

When the car "bogs for just a second" what is battery voltage reading at the battery?
NAJ is offline  
post #3 of 29 Old 02-14-2017, 07:19 PM Thread Starter
Level 2 Supporter
 
MarkassBauer's Avatar
 
Join Date: Jun 2010
Location: Clinton Township, MI 48036
 
My Ride: 92 Spirit
Engine: 2.2 MPFI
Induct: N/A
1/4: 0.000

Posts: 875
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Weird Electrical / RPM issue...

Battery stays up at around 14.5, it doesn't drop down with engine speed.
MarkassBauer is offline  
 
post #4 of 29 Old 02-14-2017, 07:27 PM
NAJ
Just A Guy


 
NAJ's Avatar
 
Join Date: Mar 2007
Location: New Jersey
 
My Ride: 1990 Daytona Shelby
Engine: 2.2 L VNT
Induct: Turbo
1/4: 15.570

Posts: 22,437
Thanks: 0
Thanked 1 Time in 1 Post
     
Re: Weird Electrical / RPM issue...

After re-reading the original post it sounds like you may have an AIS issue, either the AIS is not responding to load changes or the TB and AIS need to be cleaned.

Do you experience any similar issues when the A/C is on or the steering wheel is turned, both apply load the idle should increase to compensate.
NAJ is offline  
post #5 of 29 Old 02-14-2017, 08:04 PM Thread Starter
Level 2 Supporter
 
MarkassBauer's Avatar
 
Join Date: Jun 2010
Location: Clinton Township, MI 48036
 
My Ride: 92 Spirit
Engine: 2.2 MPFI
Induct: N/A
1/4: 0.000

Posts: 875
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Weird Electrical / RPM issue...

CRAP!!! Sorry, just happened to her again and the voltage DOES drop down to 12 or just below and she said the dash lights DO dim. But this time when it happened the radiator fan was NOT on. I recently cleaned the TB and AIS but haven't tried a new AIS which I have. She also said once in a while it seems like it doesn't want accelerate right away from stop or idle... car has NO A/C or P.S.
MarkassBauer is offline  
post #6 of 29 Old 02-14-2017, 08:19 PM
NAJ
Just A Guy


 
NAJ's Avatar
 
Join Date: Mar 2007
Location: New Jersey
 
My Ride: 1990 Daytona Shelby
Engine: 2.2 L VNT
Induct: Turbo
1/4: 15.570

Posts: 22,437
Thanks: 0
Thanked 1 Time in 1 Post
     
Re: Weird Electrical / RPM issue...

If you are losing voltage and the lights dim that takes us back to a charging issue again.

Did you check for any fault codes?
NAJ is offline  
post #7 of 29 Old 02-14-2017, 08:40 PM Thread Starter
Level 2 Supporter
 
MarkassBauer's Avatar
 
Join Date: Jun 2010
Location: Clinton Township, MI 48036
 
My Ride: 92 Spirit
Engine: 2.2 MPFI
Induct: N/A
1/4: 0.000

Posts: 875
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Weird Electrical / RPM issue...

Yea, no codes :(
MarkassBauer is offline  
post #8 of 29 Old 02-15-2017, 05:49 AM
NAJ
Just A Guy


 
NAJ's Avatar
 
Join Date: Mar 2007
Location: New Jersey
 
My Ride: 1990 Daytona Shelby
Engine: 2.2 L VNT
Induct: Turbo
1/4: 15.570

Posts: 22,437
Thanks: 0
Thanked 1 Time in 1 Post
     
Re: Weird Electrical / RPM issue...

Just to recap...
1)RPM drops momentarily with initial electrical load placed on system.
2)Battery voltage drops to 12 volts momentarily with initial electrical load placed on system.
3)RPM drops and stays low while cooling fan is on.

Questions...
1)What is battery voltage reading while the cooling fan is running and the RPM is low?
2)Exactly how low does the RPM drop with electrical load applied to system?
3)If you increase RPM to 1500-2000 and then apply an electrical load does the battery voltage still momentarily drop to 12 volts?
4)While holding the RPM steady between 1500-2000 RPM's does the RPM drop when an electrical load is applied?

Jan
1990 Daytona Shelby VNT

38 Years ASE Certified
NAJ is offline  
post #9 of 29 Old 02-15-2017, 07:28 AM Thread Starter
Level 2 Supporter
 
MarkassBauer's Avatar
 
Join Date: Jun 2010
Location: Clinton Township, MI 48036
 
My Ride: 92 Spirit
Engine: 2.2 MPFI
Induct: N/A
1/4: 0.000

Posts: 875
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Weird Electrical / RPM issue...

I can test the voltage/drop but this car does not have a tach so I won't know exact RPMs.
MarkassBauer is offline  
post #10 of 29 Old 02-15-2017, 06:28 PM
NAJ
Just A Guy


 
NAJ's Avatar
 
Join Date: Mar 2007
Location: New Jersey
 
My Ride: 1990 Daytona Shelby
Engine: 2.2 L VNT
Induct: Turbo
1/4: 15.570

Posts: 22,437
Thanks: 0
Thanked 1 Time in 1 Post
     
Re: Weird Electrical / RPM issue...

I am trying to determine if this is an electrical load issue or an AIS issue so the more info you can provide the better.

Why was the alternator replaced?
Was the problem present before the battery and alternator were replaced?
NAJ is offline  
post #11 of 29 Old 02-15-2017, 08:48 PM Thread Starter
Level 2 Supporter
 
MarkassBauer's Avatar
 
Join Date: Jun 2010
Location: Clinton Township, MI 48036
 
My Ride: 92 Spirit
Engine: 2.2 MPFI
Induct: N/A
1/4: 0.000

Posts: 875
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Weird Electrical / RPM issue...

Alternator was replaced about a year and a half ago and battery about 6 months ago. Alternator was replaced because it had a squeaky bearing, battery was replaced because it was about 7 years old and finally bit the dust do to lack of driving at that time. I'd say this issue started somewhere close to the time we replaced the battery. Back then it would also hesitate to accelerate from a stop on maybe the first 2 times of the drive, now she said it's completely random and only once in a while.
MarkassBauer is offline  
post #12 of 29 Old 02-16-2017, 06:28 AM
NAJ
Just A Guy


 
NAJ's Avatar
 
Join Date: Mar 2007
Location: New Jersey
 
My Ride: 1990 Daytona Shelby
Engine: 2.2 L VNT
Induct: Turbo
1/4: 15.570

Posts: 22,437
Thanks: 0
Thanked 1 Time in 1 Post
     
Re: Weird Electrical / RPM issue...

Start by verifying base idle is correct and reset the AIS.

TB Cleaning, Base Idle and AIS Reset
NAJ is offline  
post #13 of 29 Old 02-16-2017, 07:37 AM Thread Starter
Level 2 Supporter
 
MarkassBauer's Avatar
 
Join Date: Jun 2010
Location: Clinton Township, MI 48036
 
My Ride: 92 Spirit
Engine: 2.2 MPFI
Induct: N/A
1/4: 0.000

Posts: 875
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Weird Electrical / RPM issue...

I will do, and report back!
MarkassBauer is offline  
post #14 of 29 Old 02-17-2017, 08:40 AM Thread Starter
Level 2 Supporter
 
MarkassBauer's Avatar
 
Join Date: Jun 2010
Location: Clinton Township, MI 48036
 
My Ride: 92 Spirit
Engine: 2.2 MPFI
Induct: N/A
1/4: 0.000

Posts: 875
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Weird Electrical / RPM issue...

Ok, did the base idle / AIS reset with no luck, put the new spare AIS I had on, still no luck. It seems like all is well until idling in place for too long then gets intermittently angry..
MarkassBauer is offline  
post #15 of 29 Old 02-17-2017, 04:39 PM
NAJ
Just A Guy


 
NAJ's Avatar
 
Join Date: Mar 2007
Location: New Jersey
 
My Ride: 1990 Daytona Shelby
Engine: 2.2 L VNT
Induct: Turbo
1/4: 15.570

Posts: 22,437
Thanks: 0
Thanked 1 Time in 1 Post
     
Re: Weird Electrical / RPM issue...

I an assuming you do not have access to a scanner so I will have to think on this.
NAJ is offline  
Sponsored Links
Advertisement
 
Reply

Tags
bog , electrical , ground , power , surge

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome