1984 Omni Turns over but won't start... Please help - Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more!

Turbo Dodge Help Urgent help when something goes wrong with your Dodge and you can't figure out what the problem is. Troubleshooting help and the place to post when you're stuck with a broken car and have to get to work the next day.

 
LinkBack Thread Tools
post #1 of 11 Old 02-27-2012, 04:14 PM Thread Starter
TD New Guy
 
Join Date: Aug 2011
Location: California
 
My Ride: 578125@gmail.com
1/4: 0.000

Posts: 110
Thanks: 0
Thanked 0 Times in 0 Posts
 
1984 Omni Turns over but won't start... Please help

My girlfriend recently bought a 84 non turbo Omni for dirt cheap, but she bought it without the motor in working condition. So far I've put cap, rotor, plugs, wires, battery, and ingnition coil all new and it still turns over fine but won't start...what am I missing????? The only other things I can think of possibly keeping it from starting would be maybe a distributor or the Computer if it even has one of those. I can see an smell gas making it in the Carb so I know the fuel pump and carburetor are working.

This is driving me nuts because I'm so close and there's something I'm missing. Thanks for any/all help.

Also this was a donated/salvaged vehicle so that might make a difference. When the motor is turning over it sounds normal and seems to have average compression so I'm totally stuck.. HELP PLEASE
ArieZ is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 02-27-2012, 05:34 PM
---SITE GUIDES---
 
beeblebrox82's Avatar
 
Join Date: Jul 2010
Location: Holland, MI
 
My Ride: 87 Daytona Shelby Z
Engine: 2.5 CB TII
Induct: Turbo
1/4: 0.000

Posts: 563
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1984 Omni Turns over but won't start... Please help

I just went through this on a rebuild ... are you sure the timing is correct? how did you check compression Are you sure you're getting spark at the spark plug?
beeblebrox82 is offline  
post #3 of 11 Old 02-27-2012, 06:11 PM Thread Starter
TD New Guy
 
Join Date: Aug 2011
Location: California
 
My Ride: 578125@gmail.com
1/4: 0.000

Posts: 110
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1984 Omni Turns over but won't start... Please help

I haven't checked it with a gauge but it sounds like every other omni I've heard when turning over it just doesn't ignite.. So I'm guess it's spark but I've replaced everything I can think of. If I take the number 1 plug out and have some1 turn it over while I'm holding it is that safe?? Thats the only way I can think of to check spark..
ArieZ is offline  
post #4 of 11 Old 02-27-2012, 06:56 PM Thread Starter
TD New Guy
 
Join Date: Aug 2011
Location: California
 
My Ride: 578125@gmail.com
1/4: 0.000

Posts: 110
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1984 Omni Turns over but won't start... Please help

Ok so I pulled the number 1 plug and wire and there's no spark but everything is new.. Guess I gotta get a volt tester.. Any suggestions ideas what it could be besides what I listed I just installed??
ArieZ is offline  
post #5 of 11 Old 02-27-2012, 07:17 PM
TD New Guy
 
Join Date: Jul 2011
Location: 63627
 
My Ride: DODGE RAMPAGE
Engine: 2.2L Weber 32/36 DFEV SVDA Dist
Induct: N/A
1/4: 0.000

Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1984 Omni Turns over but won't start... Please help

Now ck the coil for spark - Same way
danbyrambler is offline  
post #6 of 11 Old 02-27-2012, 07:36 PM
Moderator

 
Jakecs's Avatar
 
Join Date: Aug 2011
Location: Oh
 
My Ride: 1988 Daytona CS
Engine: 2.2L Turbo I
1/4: 0.000

Posts: 3,073
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1984 Omni Turns over but won't start... Please help

This is a carbed car right? I'll go fetch NAJ.
Jakecs is offline  
post #7 of 11 Old 02-27-2012, 07:52 PM
Hybrid Booster
 
Join Date: Apr 2011
Location: 77042
 
My Ride: S Dakota,&G24 S Z
1/4: 0.000

Posts: 1,400
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1984 Omni Turns over but won't start... Please help

1st off what engine are we dealing with?

a) 1.6 Liter 4 cyl by Peugoet

b) 1.7 Liter 4 cyl by Volkswagen

c) 2.2 Liter 4 cyl by Chrysler

d) 2.2 Liter 4 cyl HO By Chrysler ( high output ) has a chrome valve cover.

(You haven't said if this was an early model GLH)

There is a spark control computer located beside the battery.
It would or should have a vac line attached at the top of the computer.

There was a another thing that I remember about some of the older Omni's on the firewall there was a resister it would be to the left of the brake system
looking at the front of the car. they're usually white in color and made of ceramic with a wire going into it and a wire coming out the other side. If you have this it could be blown and prevent you from starting the car. Also note that this had been used on many Chryslers from the 70's like Dart ,Monaco,Gran Fury etc.
DodgeG24Man is offline  
post #8 of 11 Old 02-27-2012, 08:00 PM Thread Starter
TD New Guy
 
Join Date: Aug 2011
Location: California
 
My Ride: 578125@gmail.com
1/4: 0.000

Posts: 110
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1984 Omni Turns over but won't start... Please help

Yeah this is a carbed car, and it has the non turbo 2.2.. I just bought a voltage tester so as soon as my girlfriend gets here ima trace electrical. But that resistor seems lika likely culprit.. Thanks for the help everyone!! I'll post more info later when I figure stuff out. Any advice is welcome!
ArieZ is offline  
post #9 of 11 Old 02-28-2012, 05:51 AM
NAJ
Just A Guy


 
NAJ's Avatar
 
Join Date: Mar 2007
Location: New Jersey
 
My Ride: 1990 Daytona Shelby
Engine: 2.2 L VNT
Induct: Turbo
1/4: 15.570

Posts: 21,937
Thanks: 0
Thanked 1 Time in 1 Post
     
Re: 1984 Omni Turns over but won't start... Please help

The ESC system basics are the same as any other ignition system.

Remove coil wire from dist cap and hold 1/4" from a good ground and crank engine.
Spark should be strong and consistant, count 1-2 sparks as no spark.

If spark is not present what is missing?
(You will need a 12 volt test lamp)
You are looking for...
Constant power at + Coil while cranking
(If power is present at + coil...
Test Lamp flashes on/off constantly while connected to a good ground and - Coil.
NAJ is offline  
post #10 of 11 Old 02-28-2012, 11:39 AM
Boostaholic
 
Join Date: Nov 2011
Location: Southern Illinois
 
My Ride: 1983 Dodge omni
Engine: 2.2l non turbo
Induct: N/A
1/4: 0.000

Posts: 696
Thanks: 0
Thanked 0 Times in 0 Posts
 
Thumbs up Re: 1984 Omni Turns over but won't start... Please help

Quote:
Originally Posted by NAJ View Post
The ESC system basics are the same as any other ignition system.

Remove coil wire from dist cap and hold 1/4" from a good ground and crank engine.
Spark should be strong and consistant, count 1-2 sparks as no spark.

If spark is not present what is missing?
(You will need a 12 volt test lamp)
You are looking for...
Constant power at + Coil while cranking
(If power is present at + coil...
Test Lamp flashes on/off constantly while connected to a good ground and - Coil.
i would definately try that!
bulldog565 is offline  
post #11 of 11 Old 02-28-2012, 04:42 PM Thread Starter
TD New Guy
 
Join Date: Aug 2011
Location: California
 
My Ride: 578125@gmail.com
1/4: 0.000

Posts: 110
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1984 Omni Turns over but won't start... Please help

Ok so I bought a check lamp and traced everything back aand found out that the new coil I just bought was defective.. So it's running now but has vaccuum problems which is easy enough now because another thread here. Thanks everyone!! Omni sounds awesome, no knOck or clack and revs great but vaccuum seems to be a issue because it's idles way to high and wants to run better with my hand slightly over the carb flaps. Thanks again for all the help!!!
ArieZ is offline  
Sponsored Links
Advertisement
 
Reply

Tags
2.2 , carb , ignition , omni , starting problems

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome