87 shelby lancer bucks surges under boost - Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more!
TurboDodge.com MarketPlace Shelby Registry Contact Us

Advertisement - Remove these ads today by clicking here.
Go Back   Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! > Turbo Dodge Technical Chat > Turbo Dodge Help


Turbo Dodge Help Urgent help when something goes wrong with your Dodge and you can't figure out what the problem is. Troubleshooting help and the place to post when you're stuck with a broken car and have to get to work the next day.

Reply
 
LinkBack Thread Tools
Old 11-16-2012, 08:18 PM   #1
87 shelby lancer bucks surges under boost  
TD New Guy
 
Join Date: Jul 2007
Location: california

My Ride: 87 shelby lancer
Engine: 2.2 t2
Induct: Turbo
1/4: 0.000

Posts: 39
Feedback: (0)
moparman7 is keeping the peace
My 87 shelby lancer 5 speed has 93000 on the clock and started surging and bucking once it goes to boost over 6psi , I replaced plug wires pick up plate in distributor
Didn't help , it runs really good if u drive it normal , only does it when you put your foot in it...
moparman7 is offline  
Reply With Quote Quick reply to this message Share on facebook
Sponsored Links
Advertisement
 
Old 11-17-2012, 06:38 AM   #2
Re: 87 shelby lancer bucks surges under boost  
NAJ
Just A Guy


 
NAJ's Avatar
 
Join Date: Mar 2007
Location: New Jersey

My Ride: 1990 Daytona Shelby
Engine: 2.2 L VNT
Induct: Turbo
1/4: 15.570

Posts: 18,761
Feedback: (23)
NAJ is keeping our cars runningNAJ is keeping our cars running
You have to determine if this is a mechanical, ignition or fuel issue.
1)Are any fault codes set?
2)What is actual pressure (boost) reading at the manifold, verify you are not actually hitting overboost shutdown.
3)Connect a fuel pressure gauge and vacuum/pressure gauge and go for a ride, is fuel pressure in specs for boost?
4)What is Map output voltage reading under the problem condition?
5)Verify cam timing and ignition timing are correct.
NAJ is offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2

All times are GMT -5. The time now is 06:28 PM.