Just bought an 87 Dodge Shelby Charger and Im having troubles.... - Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more!
TurboDodge.com MarketPlace Shelby Registry Contact Us

Advertisement - Remove these ads today by clicking here.
Go Back   Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! > Turbo Dodge Technical Chat > Turbo Dodge Help


Turbo Dodge Help Urgent help when something goes wrong with your Dodge and you can't figure out what the problem is. Troubleshooting help and the place to post when you're stuck with a broken car and have to get to work the next day.

Reply
 
LinkBack Thread Tools
Old 12-04-2012, 07:37 PM   #1
Just bought an 87 Dodge Shelby Charger and Im having troubles....  
TD New Guy
 
Join Date: Dec 2012
Location: Lewisville Tx.

My Ride: 1987 Shelby Charger
Engine: 2.2L T1
Induct: Turbo
1/4: 13.628

Posts: 27
Feedback: (0)
StaticsShelby is keeping the peace
Hey guys!! I'm new to the forums and to turbo dodges. Ive had a few Neons back in the day but that's about it.

Anyway, I found the car on Dallas Craigslist and couldn't pass up a running/driving Shelby Dodge for 1200 bucks!!

So I'm having a couple issues with the car. The first one is intermittent oil burning? The car wont puff oil even on a cold start, but sometimes at a stop light it will just start pouring blue smoke out the exhaust and the harsh stank of burning oil will fill the interior....One blip of the throttle and it goes away.... Any ideas there?

The next is really freaking me out. It's a humming noise that you can hear at 30 plus mph. It does get louder with speed. Heres the thing, I'm going to be super detailed about this noise to better help you guys help me. When I first got the car it was very loud, and I was very nervous on the 70 mile trip back home with it. It has 2 new tires up front on 15 inch American Racing wheels the guy I bought it from had installed at the dealer when he baught it new. The rear tires aren't so hot however....In fact the passenger rear rim was hit and it got bent....I noticed this when the sidewall exploded after 3 days of ownership. I put a fullsized spare on the car and the noise got a LOT quieter but its still there. And still perdy loud...

Theres a bit of a shake in the steering wheel and it sounds like the sound is now coming from the front. The kicker is that the struts and shocks on the car are so blown there isn't any damping power whatsoever so it kinda bounces like a horse wagon. The reason Im pointing this out is because here in North Dallas the roads in some places have harsh elevation changes. So picture yourself going over a bit of a hump or dip in the road. When the weight comes off the car the sound goes away. So everytime the car springs upward the sound dies....everytime the weight comes down it gets louder....kind of making this "womp womp womp" sound until its done bouncing, which is usually only about 3 to 4 times (lol). Also, as I mentioned earlier theres a bit of wobble, this sound kind of follows that wobble. The wobble is very evident when leaving a red light, so up to about 8 or 9 mph, then turns into a vibration....a big one...

Im pretty good at diagnosing and finding trouble spots, but my work schedule is out of control at the moment with me being gone days on end. So I don't really have the time to dig....but I can find time to fix....

Let me know what you think.

OHHHH And another thing is the damn speedo cable....popped out, now I cant figure out where to put it again....Looks like it goes on top of the diff under the turbo?

Please help me guys, Another thing is I'll need some tips on these cars, Like how to maintain the turbo n such stuff like that....

ONE MORE THING!!! Just recently everytime I push on the clutch pedal, even a little bit I can hear it making a rubbing noise....that's just embarrasing...

Where can I order good replacement parts for these cars at?


Specs to help....

1987 Dodge Shelby Charger
2.2L T1 engine
5-speed manual

ehhhhh, nevermind you guys know what it is....

THANKS!!!
StaticsShelby is offline  
Reply With Quote Quick reply to this message Share on facebook
Sponsored Links
Advertisement
 
Old 12-04-2012, 10:55 PM   #2
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
CHAMPION OF THE LOG


 
onerippinturbo2's Avatar
 
Join Date: Feb 2010
Location: eagleville pa

My Ride: 85 shelby charger
Engine: 2.2l sohc bored.20
Induct: Turbo + Nitrous
1/4: 12.550

Posts: 5,993
Feedback: (50)
onerippinturbo2 is keeping our cars running
the smoke, most likely a turbo going south, the wobble/viberation i'd start at tires make sure they are smooth, most times they "hump" on the rear and can flat spot from worn out suspension components, causing noise and viberations. speedo cable goes pretty much where you said, goes into the speed sensor on the trans extension housing (get the car up in the air and go under it, you'll see it then) rock auto has tons of parts for our cars, as does fwd performance and turbosunleashed and forward motion.
onerippinturbo2 is offline  
Reply With Quote Quick reply to this message
Old 12-05-2012, 07:32 AM   #3
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
Mr. Moderator

 
turbokid's Avatar
 
Join Date: Oct 2007
Location: Kansas City

My Ride: 89 Shelby Daytona
Engine: 2.4l
Induct: Turbo
1/4: 0.000

Posts: 8,884
Feedback: (5)
Images: 2
turbokid is keeping the peace
Your sound definitely sounds like flat spotted or (cupped) tires. This happens when the wheels aren't firmly planted by the suspension allowing them to bounce up and down allowing for the tires to get a very uneven tread pattern. This will make the car vibrate, cause a womping noise (thats more likely flat spots) and cause the ride to be pretty rough depending on the severity of how badly they are cupped.
The oil issue could very well be turbo seals going south. When the car gets warmed up the turbo will burn the oil off leaking past the seals. You could also have a pcv issue aswell. That would be much cheaper to check first before jumping straight to conclusions of turbo issues.
__________________
66 Charger- First car 383 4 brl awaiting paint
86 LASER xt- t1 auto ttops. Dc Aero kit and Dc intercooler kit.
89 Shelby Daytona t-top car-srt motor sittin in the bay
90 Shadow- 4 dr. VNT car
92 Lebaron GTC-1-235 factory a568 5 speed cars. t3/t4 hybrid 57 trim, 25 psi cal and other goodies =)

YES I OWN A SALVAGE YARD

turbokid is offline  
Reply With Quote Quick reply to this message
Old 12-05-2012, 12:32 PM   #4
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
CHAMPION OF THE LOG


 
onerippinturbo2's Avatar
 
Join Date: Feb 2010
Location: eagleville pa

My Ride: 85 shelby charger
Engine: 2.2l sohc bored.20
Induct: Turbo + Nitrous
1/4: 12.550

Posts: 5,993
Feedback: (50)
onerippinturbo2 is keeping our cars running
also could be valve guides/seals too or broken rings or a piston. given the the fact that the car has sat for some time leads me to turbo seals leaking, now i'm not saying to not look at the pcv, just dont decide that it has to be the pcv because it's cheap and easy to replace only to be let down when it still plooms smoke out after the pcv replacement.
onerippinturbo2 is offline  
Reply With Quote Quick reply to this message
Old 12-05-2012, 07:23 PM   #5
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
TD New Guy
 
Join Date: Dec 2012
Location: Lewisville Tx.

My Ride: 1987 Shelby Charger
Engine: 2.2L T1
Induct: Turbo
1/4: 13.628

Posts: 27
Feedback: (0)
StaticsShelby is keeping the peace
I was suspicious of turbo seals....it's very intermittent, or at least, it was....It's damn near constant now, and its also letting go of a bit of smoke under the hood all of the sudden.... As for the turbo itself, I'm not worried about it, the car pulls very hard and it spools up at the same rpm, every gear, without hesitation. Although I really don't know much about the turbos....I would have to assume this means its in perfect working order.

Here's a rookie question, these cars run a wasegate right? does this mean I cant run a bov? Or do I just install the bov in its place? As I said I don't know much about them.

You guys have been a huge help!! Ill replace the pcv and the turbo seals tomorrow....I'm assuming turbo seals and turbo gaskets are the same thing right?
StaticsShelby is offline  
Reply With Quote Quick reply to this message
Old 12-05-2012, 07:49 PM   #6
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
TD New Guy
 
Join Date: Apr 2011
Location: Rochester Minnesota

My Ride: 97 Ford F150
1/4: 0.000

Posts: 129
Feedback: (2)
93evorider is keeping the peace
No- turbo seals and gaskets are different. to do the seals you have to remove the turbo and dissassemble it completely-- most of us remove the whole head as an assembly with the turbo attached to do the removal of the turbo--- it can be removed by itself but ask anybody its a PIA-- you will also need to order the turbo rebuild kit,-- G pop shop or ebay. Also your running a TI car AKA as log setup-- so a blowoff valve is only used on intercooled cars to control the pressure in the intercooler piping and reduce turbo backpressure-- your car isnt intercooled unless someone modified it
93evorider is online now  
Reply With Quote Quick reply to this message
Old 12-05-2012, 08:20 PM   #7
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
TD New Guy
 
Join Date: Dec 2012
Location: Lewisville Tx.

My Ride: 1987 Shelby Charger
Engine: 2.2L T1
Induct: Turbo
1/4: 13.628

Posts: 27
Feedback: (0)
StaticsShelby is keeping the peace
nope there is definatly no intercooler....so I cant run a bov then ehh?
StaticsShelby is offline  
Reply With Quote Quick reply to this message
Old 12-05-2012, 08:30 PM   #8
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
TD New Guy
 
Join Date: Dec 2012
Location: Lewisville Tx.

My Ride: 1987 Shelby Charger
Engine: 2.2L T1
Induct: Turbo
1/4: 13.628

Posts: 27
Feedback: (0)
StaticsShelby is keeping the peace
Well I actually have access to a new turbo for a Volvo....are these things all pretty well the same? I'm looking at pictures of turbos and they all look the same really....
StaticsShelby is offline  
Reply With Quote Quick reply to this message
Old 12-05-2012, 09:04 PM   #9
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
CHAMPION OF THE LOG


 
onerippinturbo2's Avatar
 
Join Date: Feb 2010
Location: eagleville pa

My Ride: 85 shelby charger
Engine: 2.2l sohc bored.20
Induct: Turbo + Nitrous
1/4: 12.550

Posts: 5,993
Feedback: (50)
onerippinturbo2 is keeping our cars running
no they arent not really, some things will look the same but be different. i'm not sure you can run that turbo inside the chrysler housings, there are a few rebuilt turbos for sale in the for sale section, you can then swap over your compressor housing (unique to the log) and have a rebuilt unit or instead of swapping you compressor housing, i'd be willing to give you a housing that's been cleaned and ready to bolt on fo rthe price of shipping ( i have quite a few of them sitting around)
onerippinturbo2 is offline  
Reply With Quote Quick reply to this message
Old 12-06-2012, 08:56 AM   #10
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
TD New Guy
 
Join Date: Dec 2012
Location: Lewisville Tx.

My Ride: 1987 Shelby Charger
Engine: 2.2L T1
Induct: Turbo
1/4: 13.628

Posts: 27
Feedback: (0)
StaticsShelby is keeping the peace
Quote:
Originally Posted by onerippinturbo2 View Post
no they arent not really, some things will look the same but be different. i'm not sure you can run that turbo inside the chrysler housings, there are a few rebuilt turbos for sale in the for sale section, you can then swap over your compressor housing (unique to the log) and have a rebuilt unit or instead of swapping you compressor housing, i'd be willing to give you a housing that's been cleaned and ready to bolt on fo rthe price of shipping ( i have quite a few of them sitting around)
give me a couple days man and I will get back to you....
StaticsShelby is offline  
Reply With Quote Quick reply to this message
Old 12-06-2012, 12:01 PM   #11
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
TD New Guy
 
Join Date: Dec 2012
Location: Lewisville Tx.

My Ride: 1987 Shelby Charger
Engine: 2.2L T1
Induct: Turbo
1/4: 13.628

Posts: 27
Feedback: (0)
StaticsShelby is keeping the peace
Just got up under the hood after going to napa for a pcv valve and grommet, old pcv is not only clogged, but has been for quite some time...the crap in there is just plain out old. The outside of the valve was completely caked in old and new oil....this just may be the problem guys....
StaticsShelby is offline  
Reply With Quote Quick reply to this message
Old 12-06-2012, 12:27 PM   #12
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
CHAMPION OF THE LOG


 
onerippinturbo2's Avatar
 
Join Date: Feb 2010
Location: eagleville pa

My Ride: 85 shelby charger
Engine: 2.2l sohc bored.20
Induct: Turbo + Nitrous
1/4: 12.550

Posts: 5,993
Feedback: (50)
onerippinturbo2 is keeping our cars running
give it a try and keep us posted
onerippinturbo2 is offline  
Reply With Quote Quick reply to this message
Old 12-06-2012, 01:26 PM   #13
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
TD New Guy
 
Join Date: Dec 2012
Location: Lewisville Tx.

My Ride: 1987 Shelby Charger
Engine: 2.2L T1
Induct: Turbo
1/4: 13.628

Posts: 27
Feedback: (0)
StaticsShelby is keeping the peace
PCV made an astronomical difference!! Overall the car is running incredibly different!! However the smoking issue has not been resolved...Though its back to being intermittent again...so its still good news. ***PLEASE READ ON THERE'S MORE THAT COULD BE IMPORTANT***

Here's what I have found though while replacing the pcv valve (which I didn't need the grommet for because there isn't one) The IAC valve is cut from power....I reconnected it and the car idled perfectly....Before you say "good deal" read on....

Here's why this could be important....while letting my car idle, about every 60 seconds the idle drops about 300 rpm and the idle surges....this is when the blue smoke comes out....it only does it for a few seconds and the the idle picks up again and its fine.

After hooking the IAC back up the car sat and idled at 900 rpm for about 10 minutes with NO change....no smoke....no kick down...no surge....

I took it up to the corner store and it seemed to run like a new car!! as I pulled into the parking lot...boom...3000 Rpm....No change all the way home...still remaining smokeless though.

I cut power to it and pulled it out of the throttle body....repositioned the valve and replaced it with no power on it....Car held idle at 1000 then kicked down and surged....and theres the smoke!!

What do you guys think? ever heard of this? I read that the IAC can sometimes go past the stops and the computer will think its closing the valve when its actually opening it....I also noticed that its just a brushed 380 sized motor which has 0 degree timing
(I'm an RC car tech). So can I just hook it up with backwards polarity so the motor is spinning the right way again?
StaticsShelby is offline  
Reply With Quote Quick reply to this message
Old 12-06-2012, 02:58 PM   #14
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
TD New Guy
 
Join Date: Dec 2012
Location: Lewisville Tx.

My Ride: 1987 Shelby Charger
Engine: 2.2L T1
Induct: Turbo
1/4: 13.628

Posts: 27
Feedback: (0)
StaticsShelby is keeping the peace
Okay, so hooking the IAC motor backwards did exactly what I thought it was gonna do....Since the valve went past the stops, it was causing the valve to spin backwards....I reversed the polarity and it all evened out....Went for a 20 mile drive and no issues. Car idles just about perfectly. I also have a plugged vacuum line, and ill need to retime the engine.

Although at about mile 15 a bit of blue smoke came out at a stop light....Not much though, not even enough to have to blip the throttle...it stopped on its own. (I have 3 inch side exit exhaust so It comes out right at my door)

As for the rubbing noise, I checked the tire pressure and it was 25 psi....I aired them up and the sound is almost gone. So I'm thinking that with new shocks and struts, a set of pizza wheels (I want those American Racing wheels gone) and some new tires the car should be good to go until spring when I fix the body damage and paint it.

I absolutely love this car guys. It's fast and very fun to drive....Especially around here where people have no idea what it is.

Trans shifts smooth (occasional light grind into reverse) and linkage feels tightish....Engine makes absolutely no unwanted noises...no pings or rattles or taps....car brakes smooth....radio works....and it was 1200 bucks!!

Thanks for the help guys....if the problem comes back I'll be looking for a T1 turbo because I really don't wanna rebuild it...
StaticsShelby is offline  
Reply With Quote Quick reply to this message
Old 12-06-2012, 03:04 PM   #15
Re: Just bought an 87 Dodge Shelby Charger and Im having troubles....  
CHAMPION OF THE LOG


 
onerippinturbo2's Avatar
 
Join Date: Feb 2010
Location: eagleville pa

My Ride: 85 shelby charger
Engine: 2.2l sohc bored.20
Induct: Turbo + Nitrous
1/4: 12.550

Posts: 5,993
Feedback: (50)
onerippinturbo2 is keeping our cars running
glad to hear it worked out for the most part for ya, just keep your eye out on the for sale thread, there usually are a few rebuilt turbos that pop up from time to time.
onerippinturbo2 is offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2

All times are GMT -5. The time now is 04:15 PM.