Wipers barely work - Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more!
TurboDodge.com MarketPlace Shelby Registry Contact Us

Advertisement - Remove these ads today by clicking here.
Go Back   Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! > Turbo Dodge Technical Chat > Turbo Dodge Help


Turbo Dodge Help Urgent help when something goes wrong with your Dodge and you can't figure out what the problem is. Troubleshooting help and the place to post when you're stuck with a broken car and have to get to work the next day.

Reply
 
LinkBack Thread Tools
Old 01-23-2013, 11:06 AM   #1
Wipers barely work  
TD New Guy
 
Join Date: Nov 2012
Location: Clawson, MI

My Ride: 1987 Dodge Omni
Engine: 2.2L
Induct: N/A
1/4: 0.000

Posts: 17
Feedback: (0)
Omnipresent is keeping the peace
when I bought the car, the wiper motor was bad. So i replaced it, cleaning all of the gound points and making sure the linkage wasnt binding when i put it back together. but lately, the wipers have been so slow, to the point they cant even make a full cycle. if i lift one of the wipers off the winshield, it goes a little faster. but you would think the motor would have enough power to move the wipers, even on a dry windshield. any ideas?
Omnipresent is offline  
Reply With Quote Quick reply to this message Share on facebook
Sponsored Links
Advertisement
 
Old 01-23-2013, 11:57 AM   #2
Re: Wipers barely work  
- OFFICIAL GEARHEAD -

 
ILIKESHELBYS's Avatar
 
Join Date: Feb 2005
Location: Roswell, GA

My Ride: SC/GLHS(2)/CSX
Engine: 2.2
Induct: Turbo
1/4: 0.000

Posts: 4,303
Feedback: (29)
ILIKESHELBYS is keeping our cars runningILIKESHELBYS is keeping our cars running
Double check the ground strap, frankly its best to just eliminate the need for it by installing a jumper wire with a electrical connector on each end to go under the bolt head first, then through the wiper mounting hole then through the other end of the ground wire, then bolted to the car. The ground straps can look beautiful and new buy actually pass very little current. Also a problem with the grease in the wiper motor transmission will sometimes get hard making the motor work harder to turn the crank. The small bushings on the wiper arms need white lithium grease on them also. Beyond that I might suggest its time for another wiper motor.
ILIKESHELBYS is offline  
Reply With Quote Quick reply to this message
Old 01-24-2013, 10:51 AM   #3
Re: Wipers barely work  
TD New Guy
 
Join Date: Nov 2012
Location: Clawson, MI

My Ride: 1987 Dodge Omni
Engine: 2.2L
Induct: N/A
1/4: 0.000

Posts: 17
Feedback: (0)
Omnipresent is keeping the peace
I thoroughly cleaned the brass ground strap, but ill use some test leads to see if grounding is the problem. if it is the bushings, hopefully the auto parts store carries them. and if it is the motor, ill take it back and warranty it.
Omnipresent is offline  
Reply With Quote Quick reply to this message
Old 01-24-2013, 11:39 AM   #4
Re: Wipers barely work  
Das Beste Oder Nichts

 
92TurboTona's Avatar
 
Join Date: Oct 2008
Location: North Of St Louis

My Ride: 92 Daytona
Engine: 2.5L T1
Induct: Turbo
1/4: 0.000

Posts: 5,930
Feedback: (31)
92TurboTona is ready to make a name for oneself
auto parts store carries the bushings except for one which is a dealer item and it $10 and thats the through bushing on the crank as i went through this on my turismo
92TurboTona is offline  
Reply With Quote Quick reply to this message
Old 01-24-2013, 12:13 PM   #5
Re: Wipers barely work  
- OFFICIAL GEARHEAD -

 
ILIKESHELBYS's Avatar
 
Join Date: Feb 2005
Location: Roswell, GA

My Ride: SC/GLHS(2)/CSX
Engine: 2.2
Induct: Turbo
1/4: 0.000

Posts: 4,303
Feedback: (29)
ILIKESHELBYS is keeping our cars runningILIKESHELBYS is keeping our cars running
Like I suggested in the earlier post, the ground strap can LOOK clean and shine like a super nova and still be crap as a ground. The design is such that no matter how tight you make the bolt the connection wont get any better. The center bushing referenced above is a dealer or site sponsor vendor item as indicated. To replace that one, you mark the position of the arm that is pressed on the assembly, its a press fit and if you reassemble with the marks in a different position, the wipers will be out of time, hit the windshield trim or even worse gouge the paint on the cowl. I've rebuilt several of these and I've made the mistakes I've mentioned...including looking for hours at a problem that was the ground strap all along.
ILIKESHELBYS is offline  
Reply With Quote Quick reply to this message
Old 01-27-2013, 12:48 PM   #6
Re: Wipers barely work  
R.I.P Dennis Jarvis

 
CBMDennis's Avatar
 
Join Date: Oct 2009
Location: Saint Cloud Florida

My Ride: 1988 Labaron Convert
Engine: Turbo 2 2.2 liter
Induct: Turbo
1/4: 0.000

Posts: 5,381
Feedback: (29)
CBMDennis is keeping our cars running
Run a jumper from the battery ground directly to the ground on the motor. I bought my linkage kit from Cindy ad FWDperformance. It includes the one from the 'dealer'. On the left hand side of the screen look under Accessories , then click on Restoration. It is $14.00 for all 4 or just call Cindy at 281-288-4411

Dennis
CBMDennis is offline  
Reply With Quote Quick reply to this message
Old 01-30-2013, 09:13 AM   #7
Re: Wipers barely work  
TD New Guy
 
Join Date: Nov 2012
Location: Clawson, MI

My Ride: 1987 Dodge Omni
Engine: 2.2L
Induct: N/A
1/4: 0.000

Posts: 17
Feedback: (0)
Omnipresent is keeping the peace
thanks for the help, got the wiper in good working order this morning. the bushings were worn, but luckily the auto parts store had them all. and running the ground was a piece of cake.
Omnipresent is offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2

All times are GMT -5. The time now is 07:01 PM.