Strange noise whenever clutch is let out... - Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more!
TurboDodge.com MarketPlace Shelby Registry Contact Us

Advertisement - Remove these ads today by clicking here.
Go Back   Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! > Turbo Dodge Technical Chat > Transmission, Suspension, Brakes, Tires & Wheels

Transmission, Suspension, Brakes, Tires & Wheels This Dodge forum includes modification, tuning, repair, replacement, identification and restoration of manual and automatic transaxles, shifters, torque converters, flexplates, flywheels, ring gears, axles, and differentials including open, friction, and Q. This forum also includes modification, repair, replacement, identification and restoration of the above parts and how to tune them for better traction and handling. Also includes wheel bearings and hubs, wheel studs and nuts, wheel spacers, and other related items. Sponsored by Discount Tire

Reply
 
LinkBack Thread Tools
Old 08-22-2007, 12:03 PM   #1
Strange noise whenever clutch is let out...  
TD New Guy
 
Join Date: May 2007
Location: Schaumburg, Illinois

My Ride: 86 Shelby Charger
Engine: 2.2L Turbo 1
Induct: Turbo
1/4: 0.000

Posts: 104
Feedback: (0)
turbo-charger88 is keeping the peace
ok so when i let the clutch pedal out and the clutch engaged... i hear a grinding noise like the clutch is scraping the pressure plate or something... i dont think that is the problem, i think it is a bad throw out bearing... cuz its only when the clutch pedal is out... any ideas? if it is the throw out bearing is that a difficult procedure? any suggestions? thanks
turbo-charger88 is offline  
Reply With Quote Quick reply to this message Share on facebook
Sponsored Links
Advertisement
 
Old 08-22-2007, 12:14 PM   #2
 
Garrett Booster
 
Join Date: Jul 2006
Location: virginia

My Ride: 88 Shadow
Induct: Turbo
1/4: 12.680

Posts: 246
Feedback: (0)
cdavis is keeping the peace
You may have a clutch failure or something wrong in the trans? The only time the throwout bearing is spinning is when the clutch pedal is pressed. It may be spinning some when released but there is no load on it.
cdavis is offline  
Reply With Quote Quick reply to this message
Old 08-22-2007, 01:49 PM   #3
 
Garrett Booster
 
Join Date: Jan 2007
Location: Jacksonville, Fl

My Ride: 86 Omni GLHT
Engine: 2.2L
Induct: Turbo + Nitrous
1/4: 11.900

Posts: 188
Feedback: (6)
inline6er is keeping the peace
sometimes the throwout bearing will vibrate while its disengaged creating a rattle or squeak, and then go away when you press the clutch. Which stops the vibration. That may be the problem. If not it could be the input shaft.
inline6er is offline  
Reply With Quote Quick reply to this message
Old 08-22-2007, 03:02 PM   #4
 
TD Extreme User!
 
Join Date: May 2003
Location: CT

My Ride: 92gtc vert
Engine: 2.5 8v
Induct: Turbo
1/4: 9.800

Posts: 4,632
Feedback: (23)
crazymadbastard is keeping the peace
To replace the TOB, you have to drop the tranny. At that point inspect. My TO bearing is very noisy with a 6puck clutch, but that is par for a puck clutch.
Are you running a stock clutch?
crazymadbastard is offline  
Reply With Quote Quick reply to this message
Old 08-24-2007, 12:58 AM   #5
weird  
Naturally Aspirated
 
Join Date: Aug 2007
Location: Michigan

My Ride: 87 Daytona Shelby Z
Engine: 2.2 TII
Induct: Turbo
1/4: 0.000

Posts: 394
Feedback: (3)
docta J is keeping the peace
i think my clutch assembly is screwed up too. it makes that grinding/squeak noise when in gear and the clutch pedal is pressed down.

today, i was driving it to show my friend what was going on, and when i came up to the first light, it wouldnt come out of gear, even when the clutch pedal was floored, so it stalled. The car then wouldnt start up because it was like trying to start the car in first gear, so we pushed it out of the street, and while in motion, my friend told me to try and start it (kind of like Little Miss Sunshine) and it worked. I made it back home safely, and it seemed fine to drive when i pulled in; no stalling with the clutch pedal floored.

Also, i cant downshift into any gear unless im going about 8mph.

Thank you so much.
docta J is offline  
Reply With Quote Quick reply to this message
Old 08-24-2007, 01:02 AM   #6
 
Boostaholic
 
Join Date: Sep 2005
Location: Oshawa Ont

My Ride: Dodge Daytona
Engine: 2.2 liter turbo
Induct: Turbo
1/4: 0.000

Posts: 370
Feedback: (0)
Daytona_Geoff is keeping the peace
Have u insatalled to motor recently ? same noice for mine but my metal shield that is between motor and tranny was robbin jack it up get underneath get a friend to start it and listen.. Use jack stands lol
Daytona_Geoff is offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2

All times are GMT -5. The time now is 09:45 AM.