1985 Laser Tach not working - Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more!
TurboDodge.com MarketPlace Shelby Registry Contact Us

Advertisement - Remove these ads today by clicking here.
Go Back   Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! > Appearance > Interior

Interior Restoration or topics about the interior

Reply
 
LinkBack Thread Tools
Old 05-15-2012, 11:13 PM   #1
1985 Laser Tach not working  
TD New Guy
 
Join Date: Jan 2006
Location: Atlanta,GA

My Ride: 1988 Lebaron convert
Engine: 2.2L I-4
Induct: Turbo
1/4: 0.000

Posts: 142
Feedback: (0)
Images: 3
EliminatorTurbo is keeping the peace
so I picked up a 1985 Chrysler Laser (non turbo :( ) from some dumb kid who said it didnt work well. I changed a bunch of the blown fuses and got it to work better minus the stalling and hesitation.. but the tach doesnt work. I found another cluster and put it in but still no tach. Anyone have any idea what else I can do?
Attached Thumbnails
1985 Laser Tach not working-photo-14-.jpg  
EliminatorTurbo is offline  
Reply With Quote Quick reply to this message Share on facebook
Sponsored Links
Advertisement
 
Old 05-16-2012, 02:57 AM   #2
Re: 1985 Laser Tach not working  
Hybrid Booster
 
Join Date: Apr 2011
Location: 77042

My Ride: 383 S Dakota, 87 Z
1/4: 0.000

Posts: 1,408
Feedback: (0)
DodgeG24Man is keeping the peace
Clean contacts in connectors on rear of cluster and inside cluster that tach is mounted to, Other then that check wiring at connector for tach signal if present and cleaning is not helping then the little computer chip on top of cluster is bad. Also check the printed circut board.
DodgeG24Man is offline  
Reply With Quote Quick reply to this message
Old 01-06-2013, 12:28 AM   #3
Re: 1985 Laser Tach not working  
TD New Guy
 
Join Date: Jan 2013
Location: leduc AB

My Ride: 86 Daytona Turbo Z
Engine: 2.2L
Induct: Turbo
1/4: 0.000

Posts: 7
Feedback: (0)
Rustic4x4 is keeping the peace
i got a 86 daytona turbo z. speed-o dosent work and my tachometer is really sticky. is moves some times and when i gently hit to top of the dash it moves...any help please!!!!!
Rustic4x4 is offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2

All times are GMT -5. The time now is 04:22 PM.