Need help identifying toys option I have, aftermarket? - Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more!
SRT4 forum and Turbo Dodge Tech Lounge Help and Discussion area for the for Neon and Caliber SRT4's

 
LinkBack Thread Tools
post #1 of 2 Old 07-21-2015, 04:23 PM Thread Starter
TD New Guy
 
Join Date: Jan 2007
Location: arkansas
 
1/4: 0.000

Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
 
Need help identifying toys option I have, aftermarket?

Just picked up a 2003 SRT4 with Stage 3 with toys option. The toys option is not being used. Some kind of aftermarket system was being used and was soldered into the PCM, ran inside, and mounted below the radio in the cubby hole at the bottom. It has 3 factory looking connectors still there but no controller/switch panel. It also has a diagnostic port clipped to the wiper cowling in front of the driver.
Problem is, the car 1) won't crank with key(can jump it at the relay or starter), 2) has no power to the coil and probably the fuel pump(crank sensor signal interupted for module), 3) ambient air temp is stuck at -65*(even when jumped, meaning it is interupted also). May have a jumper in the glove box but it doesn't match any of the 3 connectors. Looks like a radio adapter. I have looked at d2mb setups and they are not even close, at least the ones I have seen.
In short, I have a new car that won't run because I don't have a control panel. References to possible solutions would be greatly appreciated.
340x is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-24-2015, 06:26 AM Thread Starter
TD New Guy
 
Join Date: Jan 2007
Location: arkansas
 
1/4: 0.000

Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Need help identifying toys option I have, aftermarket?

Figured it out. Mopar Toys option with factory connectors, missing bezel. Diagnostic connector was fuse box holder for setup.
I was looking at the wrong temp sensor also, there are two. One is ambient air temp mounted in the air tube just before the filter behind the driver headlight. The other one is the intake air temp mounted in the cold side pipe 6" from the throttle body in the short plastic tube. Its sensing element, blue tab, is exposed where the ambient air is totally sealed. Mine was damaged.
340x is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome