Trouble getting new lifters pumped up - Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more!
Turbo III Help with turbo III cars

 
LinkBack Thread Tools
post #1 of 6 Old 06-20-2016, 08:54 PM Thread Starter
Boostaholic
 
Join Date: Mar 2010
Location: LaGrange Indiana
 
My Ride: 1991 Spirit R/T
Engine: 2.2
Induct: Turbo
1/4: 12.652

Posts: 581
Thanks: 0
Thanked 0 Times in 0 Posts
 
Trouble getting new lifters pumped up

I just put in a new set of lifters from fwdperformance.com, I think they're Mercedes brand but supposed to be a direct replacment. And they seem like they're not pumping up very well. I've driven the car about 25 miles since installing them, 20 miles in 4th gear @3200 rpm. And they're still noisy and don't appear to be pumped up fully. oil pressure is great about 3/4 gauge. Just curious if anyone else has had this same issue. Here's some pictures for reference, but I'm confident I installed them properly with discs in the the right direction.
Attached Thumbnails
Click image for larger version

Name:	IMG_20160620_194637.jpg
Views:	52
Size:	86.5 KB
ID:	203466   Click image for larger version

Name:	IMG_20160620_195510.jpg
Views:	50
Size:	67.3 KB
ID:	203474   Click image for larger version

Name:	IMG_20160620_195517.jpg
Views:	58
Size:	59.4 KB
ID:	203482  

91 Spirit r/t daily driver
90 Daytona drag car
BeeZnutZ1979 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 06-20-2016, 09:27 PM
Garrett Booster
 
Join Date: Jun 2008
Location: south east Pa.
 
My Ride: 1991 Spirit RT & ES
Engine: 2.2l TIII
Induct: Turbo
1/4: 0.000

Posts: 189
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 9
 
They appear to be installed correctly. Couple thoughts:
1, did you disassemble the rockers off the shaft? Possible the oil feed hole isn't lined up to the head. i.e. Shaft backwards or on wrong side? This would be bad as the cams are lubricated up through the rocker shafts then back down into the cam bearing journals.
2, Are all the discs above the lifters installed correctly. They can flip over while pushing the new lifters in. It would be unlikely all flipped but possibly some did? The 3 slots go toward the lifter itself.
3, Any dirt in the rocker shaft could have potentially clogged your new lifters. Cleanliness is important here. A minuscule amount of debris will clog up a lifter. There's a very small spring and ball chech inside. I've tried disassembling and cleaning, never seems to work.

I have these lifters in my R/Ts, they're actually fiat lifters. INA made them originally for the TIII and I had sourced original fiat(INA) parts for mine. I have purchased both OE lifters and aftermarket for comparison. Pretty much identical, the fiats getting my vote for top quality machine work. Anyway both of my R/Ts are silent, probably the quietest TIIIs in existence, so it's not a matter of inferior parts
spirit1991 is offline  
post #3 of 6 Old 06-20-2016, 11:35 PM
Boostaholic
 
Join Date: Jul 2005
Location: Texas
 
My Ride: 87 Daytona Shelby Z
Engine: 2.2 turbo
Induct: Turbo
1/4: 0.000

Posts: 393
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Trouble getting new lifters pumped up

You can start up engine with valve cover off and see if oil is coming out of lifter / rocker assembly. If you don't see oil splashing all over the place you have an oiling problem. If this is a engine rebuild and you have 30 miles on it, you at a critical point when the oil pump craters. Change oil and Oil filter if you haven't already.


The disk should look like this when it is installed in rocker arm. The Lifter is installed rocker after the disk is in place.
Trouble getting new lifters pumped up-roller-rocker-disk-installed.jpg

Do you have some pictures of the lifters by them self especially the bottom end that comes in contact with the star lifter pad?

Ron
ntxdodge is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 06-21-2016, 10:57 AM Thread Starter
Boostaholic
 
Join Date: Mar 2010
Location: LaGrange Indiana
 
My Ride: 1991 Spirit R/T
Engine: 2.2
Induct: Turbo
1/4: 12.652

Posts: 581
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Trouble getting new lifters pumped up

I did take all the rockers off of the shafts, but did it for the intake side first and then the exhaust side after I reinstalled the intake side, I made sure to keep all rockers in order and also made sure to put shafts in correctly with the flat side towards the cam gears facing up like the fsm shows.

I made sure to be careful and held the rockers upside down when installing the lifters so the discs wouldn't flip but have no way of knowing until I pull em all back apart.

and the oil and internals of this engine are very clean, I run mobil one synthetic and changed it 3 times in 1800 miles, which is probably a waste.

and Ron I didn't take any close up pics of the bottoms of the new lifter, there from Cindy at fwdperformance. not a rebuild, motor I believe is original as far as I know and was and is still running great, just had a slight lifter tick with the stock lifters so I thought I'd upgrade to the new ones. and I'll try taking the covers off when its running and check out the oil situation.


one thing I didn't mention was while pressing some of the lifters in I got a slight shaving of the white plastic ring that goes up into the rocker, like I pressed some of them in a slight angle causing a bit of the plastic to shave off a bit.

91 Spirit r/t daily driver
90 Daytona drag car

Last edited by BeeZnutZ1979; 06-21-2016 at 01:37 PM.
BeeZnutZ1979 is offline  
post #5 of 6 Old 06-23-2016, 02:17 PM Thread Starter
Boostaholic
 
Join Date: Mar 2010
Location: LaGrange Indiana
 
My Ride: 1991 Spirit R/T
Engine: 2.2
Induct: Turbo
1/4: 12.652

Posts: 581
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Trouble getting new lifters pumped up

pulled both rocker shafts and removed all lifters to double check my install, and all discs were in the right direction. also all but one of the lifters was stuck down, like only 1 had pumped up, so I pulled the inner section out a bit from the outer section and reinstalled them, they seemed to stick out a little farther than before. only drove the car 12 miles to work this morning but no miracles yet, still ticking pretty loudly, but hopefully they pump up. also before removing I pulled the valve covers and ran engine and lots of oil coming out of the rocker holes. I'm going to put some more miles on them but if nothing changes, I'm probably going to install the original lifters with the new plastic tip retainers, cant stand the ticking engine, makes me not as excited to drive the car

91 Spirit r/t daily driver
90 Daytona drag car
BeeZnutZ1979 is offline  
post #6 of 6 Old 08-11-2019, 08:32 AM
Garrett Booster
 
Join Date: Aug 2006
Location: Denver
 
My Ride: 1991 Spirit R/T
Engine: 2.2 TIII Intercooled
Induct: Turbo
1/4: 0.000

Posts: 224
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Trouble getting new lifters pumped up

I know this is an old post but I wanted to give my 2cents since I experienced the same scenario.

I also replaced my lifters with new ones a few years ago and I also noticed at the time the new lifters where not pumping up. I didn't think much of it and figured they would pump up with oil pressure. Well they didn't and I still had real bad tapping.. So bad I stopped driving my RT.

Any way this year I decided to get back to it and started with my lifters... again!
I removed one lifter that was still compressed and took the tiny drill bit I used to tap it out of the rocker arm and I started pumping it by hand from the bottom where you can see a small ball bearing inside. I think works like a small check valve.

Well to my surprise the damn lifter pumped up and it can now be compressed and springs back like the original lifters did. Almost all my new lifters where that way!
I'm not sure if this is the answer. because I still have to put my RT all back together but I was really happy to see them now moving.
xinnix is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome