Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! - Reply to Topic

Engine - General, Exhaust & Induction Topics about the general engine items, exhaust system discussed here & Improving the intake tract - air filter to intake valve.

Thread: High idle Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-16-2019 02:07 PM
tryingbe
Re: High idle

Quote:
Originally Posted by Moparkid2.2 View Post
i know its 4 years later, but did that fix the problem?? thanks
2 piece intake manifold? If so, you left of the bolt under the elbow of the intake manifold.
08-16-2019 11:38 AM
spearscrue
Re: High idle

I had to go back to the original Throttle Body and that fixed it. I found out later that if you plan on going with the larger T.B. you have to do some port work to the intake which I wasn't willing to do.

Sent from my GM1917 using Tapatalk
08-16-2019 08:21 AM
Moparkid2.2
Re: High idle

i know its 4 years later, but did that fix the problem?? thanks
08-06-2015 09:53 AM
spearscrue
Re: High idle

The T.B. I bought didn't come with a tps or ais, pretty much stripped down. I'm going to Autozone today to buy the correct one. Another $60 Oh Well!! I am pretty confident this will fix my problem. Thanks Everyone for your help!!!
08-06-2015 05:15 AM
cheezit53
Re: High idle

The pintle is different for each TB, use the one that came with the 52mm.
08-05-2015 11:42 PM
spearscrue
Re: High idle

That certainly makes sense, I will look at that when I go to check out a new ais for a 3.0 tomorrow.
08-05-2015 10:10 PM
moparracer 35
Re: High idle

The AIS motors have different sized tips and the smaller one won't cover the hole in the larger throttle body so it doesn't shut it down to idle. Sometimes they will unscrew completely and come apart.
08-05-2015 09:03 PM
spearscrue
Re: High idle

I called Autozone and O'Reillys and had them both check the part number for the AIS motors for my OEM T.B. and a 1987 caravan with a 3.0 which is what I am assuming this 52mm T.B. Came off of and yes both Autozone and O'Reillys said they are different part numbers. Hopefully that is the problem.
08-05-2015 08:56 PM
NAJ
Re: High idle

Other than what I posted the only other things that would cause a high idle are...
1)AIS is not moving
2)Large Vacuum Leak.
08-05-2015 08:43 PM
spearscrue
Re: High idle

I consulted with Boost Button (he has been doing my programming for awhile now) prior to doing this swap and he said I would most likely not have to change any programming. I was told the A.I.S. motors were the same, the throttle cable is definitely long enough, I have not checked for a warped throttle blade yet, I think I would of caught it when I cleaned it. Hopefully I get it figured out soon the Woodward dream cruise is on the 15th. Lol!!
08-05-2015 08:05 PM
NAJ
Re: High idle

One of three things happened.
1)You increased airflow enough that the Controller/AIS cannot bring the idle speed down.
2)The AIS used in the 52mm TB is different than the AIS used in the 46mm TB.
3)The throttle plate is stuck open either due to a warped plate or the throttle cable is holding it opened.
08-05-2015 06:55 PM
spearscrue
High idle

Looking to see if anybody has ran into this problem, I replaced my 46mm stock throttle body on my 87 Shelby CSX with a 52mm throttle body and now my car idles around 2500 rpm. My car ran perfect prior to this swap. I thoroughly cleaned the used T.B. I purchased, reused the T.P.S. Sensor and A.I.S. Motor from my oem T.B. Installed a new gasket and now it will not idle down below 2500 rpm even with the idle set screw backed all the way out, I also read NAS sticky on how to reset the A.I.S. Motor and nothing has changed, I rechecked ALL my NEW vacuum lines installed last year and found no problems. Anyone have an idea on what could be causing this?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome