Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! - Reply to Topic

Electrical Help and Discussion area for any Electrical issues/diagrams.

Thread: Tach Messed Up Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-08-2019 10:06 AM
NAJ
Re: Tach Messed Up

Quote:
Originally Posted by 71hemibird View Post
Ok, I'll try that when I can move better, had knee replaced
Ooooh!!!

Take care of yourself, the car will still be there.

Best Wishes For a Speedy Recovery!!!
08-07-2019 09:26 AM
71hemibird
Re: Tach Messed Up

Ok, I'll try that when I can move better, had knee replaced
08-07-2019 07:20 AM
yellonoma
Re: Tach Messed Up

Quote:
Originally Posted by 71hemibird View Post
By the way what is the body designation for a Shelby Charger? Are they L bodies?
Yes any Omni/Horizon/Charger/Turismo/TC3/O24/Rampage/Scamp or the Shelby variants of, is an L-body

Tachs are EXTREMELY common to go to shit for the L-body clusters. Best bet is to disassembly, the tach portion can be removed, and clean the circuitry, reflow the solder joints and give it a try. If still nothing reasonable, it could then be wiring issue, tach driver (circuitry) has failed
08-06-2019 10:13 PM
71hemibird
Re: Tach Messed Up

By the way what is the body designation for a Shelby Charger? Are they L bodies?
08-06-2019 08:46 AM
71hemibird
Re: Tach Messed Up

I'll ck it when I get some more mobility, I can barely drive it right now. I was just wondering if this is a common problem. John, yes I have a whole cluster from a newer car, but it would take some work to make it work cause it has separate oil pressure and water temp gauges.
08-06-2019 07:58 AM
NAJ
Re: Tach Messed Up

I have had tach issues with my car on a few occasions in the 29 years I have owned her.

It is common for the tach's to read funny or stop working if they get hit with an electrical spike, what if anything was done to this car before the tach started to act up?

If you remove the tach from the cluster and disconnect its electrical supply does the needle still stay at 1300?
08-05-2019 11:55 AM
John83Rampage
Re: Tach Messed Up

Could be the tach itself.
Remove it and try using a can of compressed air to gentle clean it. Hopefully some dust is making it stick.
Per parts manual part number is 5209682.

Didn't you get a new cluster? Maybe your old one still works???

Don't know if the ignition switch is causing an issue?

Try testing the 3 way connector with a voltmeter.
08-05-2019 11:44 AM
71hemibird
Re: Tach Messed Up

It's an 83 Shelby Charger. John is correct about the service manual. I was just wondering if anybody has run into this before. I don't think it's electrical cause it is showing 1300 without a key even in the car.
08-05-2019 10:49 AM
John83Rampage
Re: Tach Messed Up

The '83 FSM doesn't have any diagnostics for the Tach, only the removal & installation procedures.

The tach is not connected to the instrument circuit board but rather has its own 3 way connector.

"H4" in the Tach diagram is the common ground.
08-05-2019 09:59 AM
NAJ
Re: Tach Messed Up

I do not know what type of circuit board is used on an 83, however, the problems in the newer TD's is usually related to cracked solder joints on the PCB or a connection issue with the tach drive module to PCB or Tach to PCB.

The best I can tell from my wiring is the tach signal comes directly from the - coil to the cluster, what that voltage should be???
On the newer TD's the tach voltage is 2.4 AC volts but comes from the engine controller.

Maybe John can check his 83 FSM's to see if there are tach diagnostics in there.
08-05-2019 09:46 AM
John83Rampage
Re: Tach Messed Up

Quote:
Originally Posted by NAJ View Post
83 What?
Believe it's a Shelby Charger with carb...
08-05-2019 09:33 AM
NAJ
Re: Tach Messed Up

83 What?
08-03-2019 08:34 PM
71hemibird
Tach Messed Up

The tach on my 83 just started this today. It won't go higher than 2300, or below 15, even when the key is turned off. Anybody experience this before?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome