Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! - Reply to Topic

Turbo Dodge Help Urgent help when something goes wrong with your Dodge and you can't figure out what the problem is. Troubleshooting help and the place to post when you're stuck with a broken car and have to get to work the next day.

Thread: White smoke out of exhaust. Neon SRT4. Help plz! Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Turbo Dodge Forums : Turbo Dodge Forum for Turbo Mopars, Shelbys, Dodge Daytona, Dodge SRT-4, Chrysler PT Cruiser, Omni and more! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-20-2019 06:09 PM
frankherche
Re: White smoke out of exhaust. Neon SRT4. Help plz!

White smoke usually means a blown head gasket. Check your spark plugs. Sometimes there is oil in the radiator.
08-16-2019 03:51 PM
CgPeon
Re: White smoke out of exhaust. Neon SRT4. Help plz!

Will do thanks! Decided to have it rebuilt going with this guy: https://www.facebook.com/ArtGennariTurbo/

My oil pan gasket has been seeping for a long time. I guess this would be a good time to do that and perhaps cut my balance chain.
08-14-2019 07:54 AM
tryingbe
Re: White smoke out of exhaust. Neon SRT4. Help plz!

Make sure:

Oil feedline is unrestricted and supply enough oil to the turbo
Oil return has no clogged or restriction
PCV system is working
Exhaust system is not blockage or restriction
08-13-2019 03:02 PM
CgPeon
Re: White smoke out of exhaust. Neon SRT4. Help plz!

Quote:
Originally Posted by tryingbe View Post
Failing turbo is usually the result, not the cause. You need to figure what cause the turbo to fail before putting the new one on, otherwise there is a high chance the new one will fail soon.
True a failing turbo could be a number of things. I never installed the turbo on my car. I bought the car over 2 years ago. I am going to have to ask the original owner but I think he put the turbo kit on at like 10k miles. It was a rebuilt turbo. It had a horrible tune on it when I bought it via SCT "canned" tune. (think 2008 turning options before DiabloSport) And the boost reference line for the FPR was t'd into the wrong area so I had to fix all that and get a proper email tune on it. Car was running 5w-30 full synthetic then I switched to 0w-40 since I always ran that in my srt-4's with good luck. Then I decided to switch to 5w-40 since I read of a lot of guys having good luck with that oil on their srt-4. I know journal bearing turbos are more susceptible to damage too. When I had my car on the dyno last year after a pull he turned the car off right away. :( I also have a seeping oil pan gasket that needs to be addressed.

Edit: Okay got more info. Turbo was brand new. Was installed Dec 2010. Has 11-13k miles on it.
08-12-2019 06:53 PM
tryingbe
Re: White smoke out of exhaust. Neon SRT4. Help plz!

Failing turbo is usually the result, not the cause. You need to figure what cause the turbo to fail before putting the new one on, otherwise there is a high chance the new one will fail soon.
08-12-2019 01:20 PM
CgPeon
Re: White smoke out of exhaust. Neon SRT4. Help plz!

Turbo is just about off the car at this point so can't do that test. :( I know when I had the intake off and while the car was idling I could feel suction on the breather port that is on the drivers side of the valve cover.
08-12-2019 06:39 AM
tryingbe
Re: White smoke out of exhaust. Neon SRT4. Help plz!

Do you have a vacuum gauge? If so, hook it up to the oil dip stick tube to see what kind of vacuum your crank case is seeing while your car is idling.
If your PCV system is not working, you won't see vacuum.
08-12-2019 01:36 AM
CgPeon
Re: White smoke out of exhaust. Neon SRT4. Help plz!

Quote:
Originally Posted by tryingbe View Post
I'd take the downpipe off to see if the turbine housing is wet with oil.
Quote:
Originally Posted by tryingbe View Post
I'd take the downpipe off to see if the turbine housing is wet with oil.
That I just did :) So happy its the turbo.

https://i.imgur.com/0rB9jfQ.mp4 = video showing play on exhaust side. Check out that caked on oil.





Found a little exhaust leak on my wastegate to manifold

08-11-2019 11:08 PM
tryingbe
Re: White smoke out of exhaust. Neon SRT4. Help plz!

I'd take the downpipe off to see if the turbine housing is wet with oil.
08-11-2019 09:52 PM
CgPeon
White smoke out of exhaust. Neon SRT4. Help plz!

So was driving the car a couple days ago and got on it a couple times after the car got up to temp. Once I got off my exit on the interstate and came to a stop, smoke was coming out of my exhaust like crazy at idle. Once the light finally turned green I could see it still in my mirror but not as bad. Hit another light and it was smoking quite a bit... Any how made it back home and parked it.

05 Neon SRT-4 with only 20k miles. AGP 50 trim .63 AR journal bearing turbo. Has around 10k miles on it or so. I run 5w-40 full synthetic. Prior ran 0w-40.

https://i.imgur.com/riGS6zT.mp4 Video of the white smoke

It smoked like this last year. I put a new PCV valve in and switched out checkvalves and that seemed to fix it. I also did a compression check. All were almost dead even. Low at 125 psi but it could be due to doing in the dead cold on a cold motor and I have a small battery. But it makes you wonder. Removed exhaust side of turbo and it was dry. Not caked in oil or anything. I could still smell oil burning every once in a while. Then that smell went away. I also put a new AGP oil drain tube at that time since the one that was on it was seeping and sweating like crazy.

Now fast forward to now, a full year later she be smokin' again..... So trying easy stuff first. Put a new PCV LINE on since my factory one had flat spot in it. (hard plastic line) Bypassed check valve and catch can so ran a 3/8'' line straight to intake manifold from PCV. PCV valve still looks intact and fine. Can still hear ball in there when you shake it..Idles fine. No CEL. Pulled all 4 plugs, all looked good. Oil looked clean no coolant smell. Check coolant. Still nice and clean. Started it up, once it got to operating temp it started to smoke again. :( No smoke in engine bay.

Me fingering my turbo haha: https://i.imgur.com/qU1aHsp.mp4

Seems like it has a lot of play. But not sure if that is normal on journal bearing turbos. No in and out play which is good. I contacted AGP and they said that seems a bit more then normal and asked if the blade was hitting the housing, it is not. But could be..very very close! I checked the turbo drain tube out again and took the part off on the turbo side and it didn't seem clogged or anything.

Whats next on the list?

Leakdown test?
Remove exhaust side of turbo again? Will that show if the bearings/seals are bad?
Valve seals, headgasket, Bad exhaust valve?

Thanks guys for any help. I want my car to be running great again and not smoking. Here are a couple picture of the car:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome