Turbo Dodge Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello all. Thank you for letting me join your community. I recently bought a 1987 Daytona Shelby Z . It has quite a few mods done and i dont know where to start . It runs rich at idle breaks up under acceleration and sometimes feels like ignition cuts quickly while cruising slow speed. the power loss light flashes rapidly and sometimes stays on while driving. it never displays key on flash codes. also seems to be lean under boost at 12ish to 1. The turbo is slow to spool and generally lazy. The boost is set to 12lbs, the fuel pressure is 43lbs vacuum on, timing is 12 degrees. I was thinking of adapting a Holley terminator X. Thoughts? BTW, I owned the twin to this car in the 90s and it was stock. My stock Daytona would walk all over this one.
 

Attachments

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Is the engine or power loss light on all the time? No?could be as simple as the line blown off the map sensor. You should be getting at least 55 when your checking the codes.
Checking codes
I checked all vacuum lines. i just bought a vacuum manifold to replace existing hoses and splices. Code 55 does prove out, just never and trouble codes. the engine doesn't surge or chug at idle but the wide band sets at high 10's low 11's at idle. my bumper cover gets black with carbon from exhaust. While driving the power loss light will either stay on for a while then go off again or, flash on and off rapidly.
 

·
Registered
1992 dodge shadow es turbo
Joined
·
907 Posts
Do you know what mods were done, like what smec or calibration, injectors, map sensor(2 or 3bar), Turbo and other engine work
 

·
Registered
1992 dodge shadow es turbo
Joined
·
907 Posts
Make sure your barometric solenoid vacuum lines are hooked up right, that rich at idle seems like a map sensor issue but it could be due to mods done incorrectly.
 

·
Registered
1992 dodge shadow es turbo
Joined
·
907 Posts
Looks like the only thing missing is a good ported cylinder head. Fwd cals do need to be fine tuned with the fuel pressure but that’s definitely not your issue.
 

·
Registered
1992 dodge shadow es turbo
Joined
·
907 Posts
If and when I get this sorted what wheel hp should I expect to see and 1/4 mile et and mph from this combo?
That all depends on how much boost you run, should be able to see close to 300hp but with a stock cylinder head I would think you would need to run 25psi+ For boost. 1/4 mile is all in the 60ft time so with slicks low 13’s maybe high 12’s, probably in the 105 to 110mph.
Only really one way to know for sure though, dyno and strip
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
I'm going to check compression check timing belt instalation re run the vacuum lines and all the engine grounds. Also the cam gear is adjustable. I have no idea how its phased. It just seems odd to me that the power loss light is almost always on while driving but no trouble codes are ever set.
 

·
Administrator
Joined
·
25,991 Posts
I cannot open your attached PDF's.

Running as rich as you are is going to be caused by...(Stock and Modified)
1)Map Sensor Circuit (Pneumatic or Electrical) or Incorrect Map Sensor (2 Bar/3 Bar)
2)Low Engine Vacuum (Below 15" HG)
3)High Fuel Pressure
4)Injectors Too Large for Setup
5)Injector Control Circuit
6)Incorrect Calibration
 

·
Registered
Joined
·
3,223 Posts
Welcome !!

Everything above and:

You need to double, triple and quadruple check cam timing.

Cam timing has been the root cause of many problems over the years.

Retarded cam results in a lazy, poor performing Engine, start there.

Best of luck, lots of good help here.

Thanks
Randy
 

·
Registered
Joined
·
3,223 Posts
Right, its imperative the rotor points at #1 plug wire with crank at TDC and cam zero.

Come to think of it there were some mis-indexed adjustable cam sprockets.

I think I have one somewhere.

Post some pics if you can.

Thanks
Randy

PS: Good article on cam timing. Cam Timing and Belt Tension 84-95 2.2/2.5L
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #16 ·
Thank you everyone. I'll get to it and let you know. I know this car should be fairly quick with its current setup, but its not. My old Shelby would spin the tires through first and spin second under boost. This car wouldn't think of it lol.
 
1 - 16 of 16 Posts
Top