Turbo Dodge Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I put a new engine in my 1988 Lebaron two years ago. Car finally runs well, but ever since then my Traveler does not do any fuel mileage calculations. I’m wondering if I didn’t hook something back up, or if the unit is bad and it was just a coincidence that it happened after the engine swap. It’s the simple Traveler with just a couple buttons and it powers up and acts normal other than no mpg calculation.
 

·
Administrator
Joined
·
24,437 Posts
Is your speedometer working?

Besides the Trip Navigator does this vehicle have an Electronic Monitor and/or Electronic Cluster?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
Just caught electronic monitor. Is that the display that shows doors open? Mine is the one from a Daytona I swapped in with a boost gauge my Lebaron didn’t have. I haven’t paid attention if that is working.
 

·
Registered
Joined
·
2,323 Posts
the 2 button traveler was used on 87-89 Lebarons only

got a pile of them if you need any

4374043 or 4437110 are the Mopar #s
 

·
Administrator
Joined
·
24,437 Posts
According to the wiring the Trip Navigator, Electronic Monitor and the Electronic Cluster all communicate with each other and the "Distance Signal" travels to all.

Unfortunately I do not know what should be on that line and I do not have any 88 FSM's to check for Diagnostics on the "Traveler System".

I can send you the wiring through PM.

1988 FWD Passenger Car FSM's
https://www.ebay.com/itm/3-1988-CHRYSLER-SERVICE-MANUAL-FRONT-WHEEL-DRIVE-CAR-Engine-Electrical-Wiring-Di/401808411292?hash=item5d8da5ca9c:g:naAAAOSwlbZdIpzu
 

·
Registered
Joined
·
17 Posts
Discussion Starter #12
Interesting. I was hoping there might have been something simple I left unplugged when I replaced the engine. I thought it was operating properly before then engine swap but I drive it so little I wonder if it had been out for a while. The diagnostic test looks promising.
 
1 - 13 of 13 Posts
Top