Turbo Dodge Forums banner
1 - 3 of 3 Posts

·
Registered
1990 dodge Daytona
Joined
·
62 Posts
Discussion Starter · #1 ·
Hey guys I just recently got the new clutch in my Daytona but it had been sitting a while. The battery was pretty dead and I had to jump it and well it wouldn’t stay running wasn’t charging noticed the alternator was making noise and I could see black gunk from the power steering and oil leaks I fixed had slung on the belts and got in and on the alternator. I bought a refurb alternator and put it in the car and it was charging fine at idle for a couple minutes. I decided to zoom down the road and back and as soon as I pulled in the driveway it died. The voltage gauge was showing fine the whole time thought that was weird. I’m not sure what all the connections on the alternator are for and where they go does anyone have a wiring diagram I could go off of so I can check my wiring?


Sent from my iPhone using Tapatalk
 

·
Administrator
Joined
·
25,735 Posts
I assume this is a VNT car?

Have you checked for stored fault codes?
Charging system fault codes are...
16 - Loss Of Voltage Sense
41 - Alternator Field Circuit Not Switching Properly
46 - Battery Voltage Too High
47 - Battery Voltage Too Low

It is near impossible to not connect the wires properly.
(Disregard the numbers in the photo, they are for something else.)
Tire Light Automotive tire Alloy wheel Motor vehicle


I will send you the wiring through PM, if there are codes stored then I can send you the proper diagnostics.
 

·
Registered
Joined
·
567 Posts
Hey guys I just recently got the new clutch in my Daytona but it had been sitting a while. The battery was pretty dead and I had to jump it and well it wouldn’t stay running wasn’t charging noticed the alternator was making noise and I could see black gunk from the power steering and oil leaks I fixed had slung on the belts and got in and on the alternator. I bought a refurb alternator and put it in the car and it was charging fine at idle for a couple minutes. I decided to zoom down the road and back and as soon as I pulled in the driveway it died. The voltage gauge was showing fine the whole time thought that was weird. I’m not sure what all the connections on the alternator are for and where they go does anyone have a wiring diagram I could go off of so I can check my wiring?


Sent from my iPhone using Tapatalk
Sounds like a dead battery dragging the system down and stalling it. Try to bring it to Autozone for a free charge/test. Also get new terminals. Many cars have issues due to $5 corroded terminals.

Also you can damage an Alternator trying to run it with a dead battery.

You can use a $10 multimeter to check alt output after.
 
1 - 3 of 3 Posts
Top