Turbo Dodge Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13,453 Posts
Discussion Starter #1
Heard about this trick a while back and thought I live in AZ, have working a/c, big aftermarket radiator and a big front mount intercooler so I would be the perfect candidate to try it. If it doesn't work, waterpump is cheap.


 

·
Registered
Joined
·
13,453 Posts
Discussion Starter #2
Drove to work on the May 13 at around 73F ambient, Megasqurit logs show no issue.
93F ambient today and drove the entire trip with a/c on all the way.
Highest temp at idle was 201F.
75mph(around 3000rpm) on freeway with a slight uphill for 10 minutes was steady 191F - 193F
 

·
Registered
Joined
·
1,830 Posts
Harry,
Have you done any work porting the housing? That short turn on the CB pumps is horrendous. To fix it properly, one would really need to weld up that area first, so it could be properly ported. That is one reason why I typically use the early pump and housings on CB's.
It would be interesting to test the flow rate of a 3 bladed CB pump vs. the much smaller 6 blade early pump.
 

·
Registered
Joined
·
13,453 Posts
Discussion Starter #5
Harry,
Have you done any work porting the housing? That short turn on the CB pumps is horrendous. To fix it properly, one would really need to weld up that area first, so it could be properly ported. That is one reason why I typically use the early pump and housings on CB's.
It would be interesting to test the flow rate of a 3 bladed CB pump vs. the much smaller 6 blade early pump.
Some light porting and smoothing, nothing to the extreme.

I do have a second pump housing here, but it's gonna be 109F next week.
 
1 - 6 of 6 Posts
Top