Turbo Dodge Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter · #1 ·
Hi, im a new owner of a 87 shelby z daytona.. i have a problem, the cars running way to rich, the current setup is an adjustable fpr, +40 injectors, 255lph pump, my question is what fuel pressure should i be running at? i cranked the fpr all the way down and the lowest i got was about 35psi :( shouldnt i be at 29 or so? any ideas? is the pump flowing to much for the fpr?

Thanx.

-Bob
 

·
Registered
Joined
·
1,597 Posts
I you're running the stock computer, then yeah it's going to be rich. I ran my 89 lebaron that way (was waiting on new stage5 cal) and I had the pressure down around 37lbs. It was really rich, but not enough to foul spark plugs. Just wasn't getting the best gas mileage!
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #3 ·
Hmmmm well i havent checked to see what ecu it has im pretty sure i saw a mopar performance sticker on it... illl have to check. i think i have a stage 5 ecu laying around i could try that. oh and when i adjust the fpr do i have to remove the vacume line or can i do it with the vacume line hooked up?
 

·
Registered
Joined
·
1,597 Posts
Well, since you said you were the "new" owner, one would hope that the previous owner would have bought a computer to be able to run those injectors at close to the stock fuel pressure. What's telling you that it's rich? Do you have any type of air/fuel ratio gauge on the car? Have you check the engine codes? Fuel pressure is supposed to be check with the vacume line off.
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #5 ·
it huffs black specialy under boost, my eyes and nose burn like hell and you can light the exhaust on fire lol... and it wont rev past 5k just stumbles and huffs black (probably fouled the plugs) ahhh i did it with teh vacume line on... sigh.. human error. no i havent checked the codes yet ill do that once i get a jump to start it again lol. small tractor battery dont do to good in the cold and remote mount.
 

·
Registered
Joined
·
1,597 Posts
Unless it's a super 60 computer, mopar perf. computers are not going to run those injectors correctly either. There made for stock injectors, as they only up the boost to right around 14lbs( may vary a little by year). If you have a stage5 cal for the 87 cars, and a 3bar map sensor, then get it in there! 35lbs with the line on will be 40-45lbs with the line off.
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #7 ·
i have no clue what map it has, frankly im not sure where the map is lol. if i recall there mounted on the ecu? i was gonna sell the stage 5 ecu but if its what i need then i guess not.
 

·
Registered
Joined
·
1,597 Posts
87 cars can have it mounted on the logic module(passenger kick panel), or in the engine bay on the passenger side strut tower. If it's on the LM then I guess you would have to wire in an external map sensor, so you could use a 3bar map(I don't think they make one for the LM mounted map sensors). If it's mounted under the hood you can tell it's a 3bar because it's larger than a stock one(if you have a stock one to compare it to). Also if you unplug the sensor, you would be able to see where someone had to cut a notch in the factory plug because the 3bar has an extra notch in one of the holes that our 2bar doesn't.
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #10 ·
ok best guess, the distribitor died. got it started. as soon as i touched the dist it died dead. and when it was running at idle the tach showed 4500-6k so imma slap a spare dist in it and see what happens... oh and thats after putting in the stage 5 ecu. quick question. a t1 dist will work in a t2 right?
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #13 ·
ok so how about a stage 5 ecu and plus 40's? since im getting a 3bar map put i so i can use my stage 5ecu. what should the fuel pressure be at? 55psi like stock?
 
1 - 14 of 14 Posts
Top