Turbo Dodge Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Hey out there, My Tona is making some trany noise. It functions well except for returning to 4th from 5th, it doesn't grind but it doesn't go into 4th either. I'm not sure but I think the fork may be off?!? Help me here? And over all it whines! from zero to go it makes a weird noise like when a steering pump is going out. The noise doesn't really change pitch or anything I just wonder why. My bud says he thinks the bearings are going out which is feasible as there is 160k on the ODO, but he isn't really a car guy. So please if you can help me from playing the fix this and then oops it was this so it'll cost you even more this time game I would be greatly appreciative. Jim
 

·
Registered
Joined
·
44 Posts
Discussion Starter #2
I'm retarded

I've never drove a car that had this shift pattern, my mechanic drove it and told me I was crazy. Then he explained that the shifter goes down and left then into 4th not just straight down?!? Oops.
 

·
Registered
Joined
·
2,621 Posts
What kind of tranny has 4th directly below 5th? The pattern is pretty much the universal standard, other than reverse being up to the left.

The whining could be low oil level.
 

·
Registered
Joined
·
3,340 Posts
What kind of tranny has 4th directly below 5th? The pattern is pretty much the universal standard, other than reverse being up to the left.

Yugo F1 ????????
 

·
Registered
Joined
·
805 Posts
The whine is very common in 555 tranny with high miles or big power. The trans will need to rebuilt and have new bearings, fluid, and moly plate installed.

Best Regards
BIG PSI
 
1 - 5 of 5 Posts
Top