Turbo Dodge Forums banner
1 - 14 of 14 Posts

· Registered
Joined
·
438 Posts
Discussion Starter · #1 ·
I have a '93 Daytona IROC RT with TIII engine that the AC Clutch, rear window defroster, Overhead console not working and Airbag light on.
A lot problems started going bad about two years ago when the overhead counsel stopped working after cold weather, a short time later the airbag light came on. I've changed clock spring and have check the AIR bag module with other modules and no difference found. The two air bag impact sensors are also good on front of car.

Last year the AC clutch will not engage, yes it has Freon and the wire continuity and power to Power module. I have 12v power from Low and High pressure sensors on AC Freon line. The rear window defroster failed about the same time the AC cratered.

All Fuses and relays are good for AC but the clutch will not engage. I have hot wired the AC clutch and it does engage when 12v power is applied
I have changed the ignition switch on the steering column with no change in symptoms.

From the Daytona schematic it reference a F20, what is it and where is this located ? The schematic also reference instrument panel on one of the pages. The F20 power up the Airbag, AC clutch, rear window defroster and overhead counsel from the wire diagram .

Ron
 

Attachments

· Administrator
Joined
·
26,356 Posts
If I am reading this correctly you have 4 separate issues or are you thinking they may be related?
You need to find someone with a scanner that can access the SRS module to retrieve the codes.
The overhead console is BCM controlled so again, a scanner is needed to access the BCM.
In some instances if there are certain codes stored the engine controller will not allow you to have A/C as a safety precaution, once again a scanner is required to view all engine data.
(DRBII or Snap On MT 2500 with the CCD Bus Connector Cable, I do not know if the OTC Monitor 4000E has the ability to communicate with the BCM or SRS module.)
Later today I will look at the wiring and see if I can get more info.
 

· Registered
Joined
·
438 Posts
Discussion Starter · #3 ·
Hi NAJ, Unfortunately I don't have a scanner. The car has power 12V going to AC controller (center dash), Rear defroster/Side mirrors (center dash), and overhead counsel (roof center but currently not installed). Grounds look good at all locations also.

The AC relay (under hood drivers side) seems to not get 12v which I believe comes out of the Power Control Module (left front fender). This is a '93 and the PCM is particular to the '93 IROC RT.

I've contemplated the BCM (passenger side kick panel) as a possible problem and the PCM (Left front fender). I have change out the SRS module (center floor under dash) with two other units with no change.

If you are correct in your thinking the PCM may have code in it that won't allow the AC clutch to activate may be the issue. As I stated above the car started having problems about two years a go when Texas had extended cold spell in the 10 -20 degrees for ten or so days. You probably remember from news reports. This is California and Texas car and not use to extended cold weather. I'm thinking the cold may have cratered some of the electronics and something is slowly dying.

Car engine other wise is running great.
Ron
 

· Registered
Joined
·
438 Posts
Discussion Starter · #4 ·
An added note, the radiator fan is operating correctly and cooling when engine temperate needs the fan to turn on and off when engine cools down.

The radiator fan should turn on along with the AC Clutch when the AC button is activated. When the AC button is activated the radiator fan does not turn on and the AC clutch does not engage.

Ron
 

· Administrator
Joined
·
26,356 Posts
Rear Defogger...
Does the light on the rear defogger switch illuminate when you push it in (on)?

A/C Clutch Relay...
There are 4 wires, two power, one ground side control (from SBEC) and an output to the A/C compressor.
GY = Power from Fuse 52 in the PDC.
LT/GN = Power to A/C Clutch Relay from the Radiator Fan Relay
DB/OR = Ground Side Control from Cavity 34 of the SBEC.
DB/BK = Output to A/C Compressor
What if anything is missing?
You also need to check...
Does the system have enough refrigerant?
Are the Low Pressure Cutout Switch, High Pressure Cutout Switch and the Cycling Switch circuits functioning as they should?

Overhead Console...
What does the overhead console display or not display that is not correct?

Airbag...
Unfortunately without a scanner you will be out of luck, without knowing what Code(s) are stored in memory you are spitting in the wind.
The issue could be anything from a Fuse, Air Bag Module (on the steering wheel) any connector/wiring issue from the column to the SRS Module, or to the Front Crash Sensors.
 

· Registered
Joined
·
438 Posts
Discussion Starter · #6 ·
Updates below italicized and bold

Rear Defogger...
Does the light on the rear defogger switch illuminate when you push it in (on)?
- No light comes on it is dead. It does have the 12 volts at the connector and ground. I have tries some used switches and same results.

A/C Clutch Relay...
There are 4 wires, two power, one ground side control (from SBEC) and an output to the A/C compressor.
- I did point to point to relay from PDC connector see attached for turbo III. Hand drawing is the Ac clutch relay on pin 27 PDC harness Pin 6 on rely has no continuity. I have to tear into harness to see if there is a break somewhere. Over all inspection doesn't show any breaks.
GY = Power from Fuse 52 in the PDC. - What pin on the PDC connector is this? I will have to check.
LT/GN = Power to A/C Clutch Relay from the Radiator Fan Relay - should be positive 12 V
DB/OR = Ground Side Control from Cavity 34 of the SBEC. - Yes it is Ground
DB/BK = Output to A/C Compressor - this is Ground from my diagram
What if anything is missing?
You also need to check...
Does the system have enough refrigerant? - Yes it has R134 charge on it.
Are the Low Pressure Cutout Switch, High Pressure Cutout Switch and the Cycling Switch circuits functioning as they should? - I have 12 volts through Low and High pressure cutouts.

Overhead Console...
What does the overhead console display or not display that is not correct? - It is dead nothing lights up and currently disconnected. The primary wiring connector does have the 12V and ground. This has multiple contact on the connector for various inputs.

Airbag...
Unfortunately without a scanner you will be out of luck, without knowing what Code(s) are stored in memory you are spitting in the wind.
The issue could be anything from a Fuse, Air Bag Module (on the steering wheel) any connector/wiring issue from the column to the SRS Module, or to the Front Crash Sensors.
- I think I'm screwed on this one. possibly air bag is bad.

Ron
 

Attachments

· Administrator
Joined
·
26,356 Posts
I will be home tomorrow to look in my BCM Diagnostics Manual and look over the other issues.

Are there any TD members that live close by that may have a scanner and correct cables?
 

· Registered
Joined
·
438 Posts
Discussion Starter · #9 ·
Well I had some time to checked out a few things tonight. I swapped out the Power Module ( driver side fender) with no change. I also discovered the back up lights don't work tonight .

All the components that don't work:
  • Air Bag light stays on
  • Back Up Lights don't work
  • AC Clutch won't engage - NO AC
  • Rear window defogger doesn't work
  • Console Navigation and temp won't turn on
These are all on the same circuit.on the F20 "BUSS Bar" off of the ignition an fuse #5. Fuse #5 (backup Lights) and Fuse #1 ( HTR-AC) are good. My next thing is to see if I have a body controller passenger side kick panel.
 

Attachments

· Administrator
Joined
·
26,356 Posts
I posted diagnostics for all of these issues except the backup lamps which are simple.
With a manual trans the backup lamp switch is just on/off.
You should have power all the time, when in reverse the switch closes allowing power to the backup lamps.
Use a jumper wire and jump the two terminal connector for the backup lamp switch and turn the key on, the backup lamps should illuminate.
If they do replace the switch, if they do not, what is missing, power in, power out of the switch or power at the backup lamps?

 

· Registered
Joined
·
438 Posts
Discussion Starter · #11 ·
It's finally gotten cooler in Texas and I can go outside without dealing with 100 degree heat at 9 PM. I've come to the final conclusion the BCM is Toast on my '93.

I'm looking for a BCM for '93 Daytona IROC R/T. The BCM Part number is 4672293.
Let me know if you have one. Thanks, Ron
Font Gas Machine Audio equipment Metal
 

· Registered
Joined
·
2,764 Posts
1993 part book Daytona:

MODULES
G-BODY
A 04686003 Theft Alarm, (Bracket 4503087)
B Lamp Outage (Bracket 4503085)
C 04723352 1 Airbag Diagnostic (Use Insul. 4443958 2-Way & 4209939 10-Way)
D 1 Body Controller, (Basic) (Spacer & Stud 5266113) (Clip J4175266) (REPAIR
CENTER)
Premium (REPAIR CENTER)
E 04672021 E.A.T.X. (Mtg. Screw 6033882) (Use Insul. Pkg., 4419491)
F 05234235 1 A.B.S. Control (Use Insul. 4419494)
04688012 A.B.S. Control
G 1 Intermittent Wiper
04437394 Daytime Running Lamp

Rectangle Slope Font Parallel Drawing
 

· Registered
Joined
·
438 Posts
Discussion Starter · #14 · (Edited)
Update: Roughly three weeks ago on a Wednesday or Thursday (it’s all running together at this time) I removed the glove compartment door and in the process while removing the lamp on the glove compartment door light switch I blew Number 5 fuse. All the interior light went out when this happened. I replaced the 20 Amp fuse and all the interior lights came on. I did rearranged the pink wire and the ground wire on the glove compartment light switch as they were very close to the metal cross bar brace on the lower dash board. I restarting engine and all the options that failed were still not working. Airbag light was ON, AC didn’t work, rear window defroster did not work and back up lights were out. I’m flabbergasted, cursed and give up for the night in frustration.

Fuse #5 20 Amp is for backup lights and they weren’t working for quit some time, fuse # 26 10 Amp is for interior lights and this fuse did not blow.

I got in car a few days later to move it and the radio (Pioneer aftermarket) seemed to lose power or reset itself over the past few days and the Air bag light amazingly went OFF.

Holly Crap what's going on, I pushed the AC button and after 2 summers the AC clutch engaged and cold air was coming through the vents. I pushed the rear window defroster button and the light on the switch came on. The rear backup light were also working.

In short everything is working with exception of the Temp and Navigator on the roof of the car. The only thing I can think of is the ground wire from the glove compartment door light was touching the grounded bar support the lower dash board, and somehow after sitting a few days the BCM reset itself.

I have been driving the '93 Daytona IROC R/T daily the last few weeks and reassembling all the dash board covers slowly. Knock on Wood and I'll cross my fingers that the problem went away after the fuse blew and somehow the BCM reset itself after sitting a few days.

YAHOO !!

Ron
 
1 - 14 of 14 Posts
Top