Turbo Dodge Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
840 Posts
Discussion Starter #1
My 94' shadow 2.2L puffs black smoke when I first start it up every day, and runs rough till it warms up a bit, it also puffs black smoke when it floor it going down the road.
I have a new mopar O2 sensor in it (with a good ground wire) and a gutted out cat, also the coolant temp sensor, and tps are new and all mopar.
 

·
Banned
Joined
·
1,695 Posts
d_snook6 said:
My 94' shadow 2.2L puffs black smoke when I first start it up every day, and runs rough till it warms up a bit, it also puffs black smoke when it floor it going down the road.
I have a new mopar O2 sensor in it (with a good ground wire) and a gutted out cat, also the coolant temp sensor, and tps are new and all mopar.
you could keep throwing more parts at it. maybe have a qualified mechanic connect a scanner to analyze data. I personally would check the obvious things like fuel pressure, map sensor reading, vacuum lines, etc.
 

·
Banned
Joined
·
1,695 Posts
Turbo Charger said:
Sounds to me like your oil rings are shot/worn.
Uhhh NO, ring failure causes smoke under hard accelleration. smoke when first starting or at idle is valve guides and seals. however he states it's black smoke which is not oil related as oil gives a bluish color.
 

·
Registered
Joined
·
840 Posts
Discussion Starter #5
Turbo Charger said:
Sounds to me like your oil rings are shot/worn.
nope, the engine had new rings, and was honed about 20k ago.
And honestly i don't really care anymore why it smokes cause i found a 3.0L and 5 spd with 152 000km on it, i might get it and swap that in. The car is only a winter beater (mind you the car has no rust at all) and my turbo Duster will be on the road in 2 weeks so i decided to not spend any money on fixing a car that i won't be driving at all for 4 or 5 months.
 
1 - 5 of 5 Posts
Top