Turbo Dodge Forums banner
1 - 6 of 6 Posts

· Premium Member
Joined
·
191 Posts
Discussion Starter · #1 ·
Just reinstaled the valve body and the linkages do not line up?!
The lever is push up against the manuel valve on the VB. The manuel valve does not go in any further it must be up against the trany housing on the other side.I just removed it to have better access to the governer,And now the lever won't go in park. It's travel ends in the reverse position. I did not touch any ajustement! So what's up??What I'm I overlooking!!??
 

· Premium Member
Joined
·
191 Posts
Discussion Starter · #3 ·
God D...!! I looked on all the threads and pictures and always saw it on the extrimity. I should have known that it went in between the first and second ring or bulge(whatever you call it. Right!!?)so that the lever can pull or push it. I feel like a jerk I must of took it off 5 times blew a fuse or two.:mad:I soon as I read your reply.Bang! :bang head.Thanks, I will go finish it now.:thumb:
the rooster comb tab is not in the manual valve slot
 

· Banned
Joined
·
1,701 Posts
God D...!! I looked on all the threads and pictures and always saw it on the extrimity. I should have known that it went in between the first and second ring or bulge(whatever you call it. Right!!?)so that the lever can pull or push it. I feel like a jerk I must of took it off 5 times blew a fuse or two.:mad:I soon as I read your reply.Bang! :bang head.Thanks, I will go finish it now.:thumb:
as Carlos Mencia would say "dee-de-dee" :thumb:

sometimes when things just don't go right, ya panic, have a hissy fit before you open your eyes and analyze the problem. amazing how easily that happens with the ease of having the internet.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top