Turbo Dodge Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
Hi,

Recently I installed a switch to manually engage lockup on my transmission in my Shadow. After about 2 months of driving around with lockup on almost all the time (pulling it into 2 to disengage) and leaving it in lockup while under boost it has finally had enough. I know that was a bad idea. ;)
While crusing along at about 35mph the revs suddenly jumped and it was finished. When I now engage lockup the revs drop slightly but the converter is certainally not locked. :bang head
It seems that it is only slightly engaging. In the mean time I've unplugged it completly; however I would really like to have lockup again.
Any ideas as to what I have broken and what is needed to fix it? :confused:
Thanks in advance.

[94 Shadow, Turbo 1, 3spd NA tranny with 37k miles on it]
 

·
Registered
Joined
·
2,028 Posts
The lock up converter has a clutch in it that locks up, you obviously broke that, so you need a new converter.

If you want to use the lockup under boost you have 2 options, get another stock converter and have it last 2 months again or buy an aftermarket lock up converter(call Pats Performance Converters)

Or you can use a stock converter like normal meaning no lockup in boost like the factory computer does and it will last
 

·
Registered
Joined
·
353 Posts
When I used a lock up tranny and a manual switch the revs only fell about 300 with its lock up.
 
1 - 8 of 8 Posts
Top