Turbo Dodge Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
I've got an 05 srt4 and bought the AGP wastegate actuator. I hooked it up a couple different ways and can't seem to figure out how to get it to work. The car will build boost very quickly, but it will overboost. I have a controller hooked up and it is adjusted down to the minimum, but the actuator is still overboosting. any suggestions? The instructions don't seem to be enough. Does the actuator rod need to have any slack...help :bang head
 

· Registered
Joined
·
1,001 Posts
I'm not too familiar with srt's, so here goes. Is the AGP arm adjustable? if so, it sounds like it isn't allowing the swingvalve to open. Just a thought. Maybe try removing the controller until you get it running right.
 

· Registered
Joined
·
3 Posts
The rod doesnt need slack. I had this same problem with my agp wastegate too. Check and make sure the hoses connecting to the wastegate and the turbo are hooked up right. if your directions arent good enough than call the AGP tech support hotline thing adn they can walk you through the steps of hooking it up right. it can also be very tedious trying to tune it to boost what you want so be patient. but if you tried every way to tune it than i am almost positive you have to change the hoses around. good luck.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top