Turbo Dodge Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
257 Posts
Discussion Starter · #1 ·
My alternator isint putting out any voltage !!! So I changed the alternator and still nothing so i went through the harness checking for any shorts but to no avail. My friend tells me that i got a bad alternator but i had it tested a autozone and it tested good. I bought three other ( two denso's and a bosch)alternators since then but the same thing happens, no charge (URRGGHH) so i figured if it was'nt the alt or the wiring it must be a bad volt regulator so i changed out the comp ( on the alternator it says thatit's externally regulated by the computer) so i changed the comp only to have the same thing no charge from the alt. What's left cause i'm completly stumped
 

·
Registered
Joined
·
3,672 Posts
Ok first what is the car we are working on engine size and all and what electronics used. The cars do use an external regulator fuel injected is inside the computer carbed cars use a regulator bolted under the hood. You sig doesn't help me with what you got.
Tim
 

·
Registered
Joined
·
443 Posts
thanks,, going to start on this after i'm over this flu
my charger did this to me pull on all the lnks to see if they feel like ruuberbands if they do its blown. my car was trying to charge it was putting out 40 volts to the hot post of the alternator just wasing getting to the battery cause of the link
 

·
Registered
Joined
·
126 Posts
my charger did this to me pull on all the lnks to see if they feel like ruuberbands if they do its blown. my car was trying to charge it was putting out 40 volts to the hot post of the alternator just wasing getting to the battery cause of the link
40 volts ,,,OMG i have never seen anything over 18 on anything :bang head
 

·
Registered
Joined
·
1,227 Posts
I had the voltage reg go out on my 92 spirit, damn near impossible to find a good SBEC II for a 5 speed spirit
 
1 - 9 of 9 Posts
Top