Turbo Dodge Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter · #1 ·
I adjusted my wastegate to all the way screwed on. not only do i boost near 15 psi but I also get better mileage. The engine also misses a lot more. I put new spark plugs in 400 mi ago, will they get temp damaged that quickly?

I just started using the cruise control too. Damn. Is it just me or do all these cruise control units just kick supreme amounts of ass. It can control the gas better than I can.
 

·
Registered
Joined
·
5,104 Posts
Plugs shouldnt be bad that quick, you can close the gap to .030 and see if that helps, if not you may have bad wires. Also, could the miss be the boost cut? Is this a OEM computer or do you have a cal in it? If its stock then it will be very violent when it hits boost cut. And lastly, 15 psi on stock injectors is not a good idea, you may be getting very lean.....
 

·
Registered
Joined
·
809 Posts
yikes! all the way in might be a bit too much for a stock setup- I only went a 1/4" and I am using +20's and a stage 1 ECU. Just tightened it enough to get a steady 15PSI that the ECU is set for. Leaning out would be a major concern if I was you.
 

·
Registered
Joined
·
241 Posts
I ran 15 pounds of boost for a few months with stock calibration and injectors and just took the head off to do a head gasket and the cylinders/pistons/plugs and everything were perfect. I was carefully monitoring the a/f ratio with the dawes meter (if that even really means anything).
Jerry
 
1 - 5 of 5 Posts
Top