Turbo Dodge Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
184 Posts
Discussion Starter #1
Thought this might be the correct forum for this exact issue.

Symptom: When I turn on mah headlights the "check gauges" (CG) light comes on.

The CG light stays on at idle, and when I put her in gear, but goes off as soon as I give her a few more rpms. Light then comes back on when she settles back to idle. All systems (oil pressure, etc. check ok and no codes). Changed the power module which seems to have fixed other issues.
 

·
Registered
Joined
·
184 Posts
Discussion Starter #3
Charging system output is too low at idle. Check your systems output.
Good input...the power module did not make a difference...will test the alt output after a test drive...cleaned the battery terminals and ground strap locations

how would i know if i have a nippondenso rebuild-able alt?
 

·
Registered
Joined
·
184 Posts
Discussion Starter #5
+1 Alt going out, or bad,corroded,loose connection

disconnected and cleaned all alt contacts ...voltmeter shows across batt ignition off 12.64V and running at idle 12.24v

engine during that short test keeps changing idle and not smooth, noisy
 

·
Registered
Joined
·
856 Posts
sounds like alternator issues.

toss in a new one or rebuild it.

gotta figure out where you are on the scale

try to fix it/rebuild ?$?$<-----------------> buy rebuilt alternator 50$.
most people have good used units laying around they would sell you..

as for me. if i take something off my car i try to replace it with a new/remaned one.
just so im not taking it off again in a month.
 

·
Registered
Joined
·
184 Posts
Discussion Starter #7
sounds like alternator issues.

toss in a new one or rebuild it.

gotta figure out where you are on the scale

try to fix it/rebuild ?$?$<-----------------> buy rebuilt alternator 50$.
most people have good used units laying around they would sell you..

as for me. if i take something off my car i try to replace it with a new/remaned one.
just so im not taking it off again in a month.
is it an upgrade to get a 120v alternator rather than a 90?
 

·
Registered
Joined
·
7 Posts
how old is your battery ? your voltage is pretty low, thats the voltage of a half charged batt while your running.... could be your batt drying up on the insides, not wanting to keep charged.... and running your alt should take that number right up to the 14v range.... and upgrade yes for sure, you will definitely notice the lack of drag on your system when you turn your air or heat on..... also a great upgrade for aftermarket sound systems
 

·
Registered
Joined
·
184 Posts
Discussion Starter #9
Yes, my "check gauges " light was flashing along with my turn signals today....got an alternator and will install tomorrow. Batt checked out good at two auto part stores, but we will see...
 
1 - 9 of 9 Posts
Top