Turbo Dodge Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Sorry if this is in the wrong place. I'm brand new. And completely clueless. I can't find answers anywhere else on the internet so I figured this would be my best bet.

Ok, so. I have a 97 Dodge Neon (don't say anything! Lol.) and there's something wrong with it.
A friend who works on cars says it's either the Valve Train or the Push Rod.
It won't go more than 10 mph. It makes this terrible clanking noise and sounds like it's about to blow up when you start the car.

I don't really have the money right now to take it to a mechanic and just have them tell me it's junk or have them charge me outta' the ass to fix it.

So! I was wondering if anyone here could possibly give me some ideas on what to do, how to go about it, or even if those things are even the problem?

:bash:
 

·
Administrator
Joined
·
25,737 Posts
Diagnosing a noise online is difficult since we cannot hear it.
First be sure the oil is full.
Is it a loud dull metallic sound, a higher pitched metallic sound, is it backfiring?
Try to determine if the noise is coming from the top or bottom of the engine.
Your Neon does not have pushrods, it is an overhead cam engine, is this a dual overhead cam or single overhead cam, if you are not sure post the last 8 digits of your VIN.
Did anything happen before the noise issue or did it just suddenly appear?
 

·
Registered
Joined
·
16 Posts
my friend had kinda the same pblm on her nissan. this sounds wierd but try unbolting the exhaust. if the cat is plugged it can not let the engine get rpms to go fast. the sound i dont really know about but hey u never know.
 
1 - 4 of 4 Posts
Top