Turbo Dodge Forums banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #1
bc this damn thing won't start. got myself some plugs, wires, a fuel filter.

when I bought the NGK's they came gapped at .044 I read somewhere it's suppose to be .041. which is right?

it has a good healthy crank but it does sound alittle off, so if this fuel filter doesn't do the trick probably gonna go check cam timing next.

Also, finally got my KYB GAJ rear shocks on, looking for something to do on the front, any suggestions? not trying to drop the vehicle so stock ride height springs prefered

just got the cam covers off and the back cam seems to be a tooth off. guessing that would be enough to keep it from firing? oh and I'm having a hard time reading the numbers on the crankshaft timing plate thing, anyone got a good picture
 

·
Registered
Joined
·
136 Posts
Discussion Starter #2
well they are lined up, it was 180 out on the crank or something close to. it sounds like the motors cranking on like 5.5 cylinders. perhaps a compression issue? don't really seeing that being the issue tho bc it has been running good, or atleast decent. the fuel pump kicks on, new filter and the junk that came out wasn't that bad, some sediment but real clear. the asd relay energizes.

the motor just seems to have a kick of sort when it's cranking that's why I said 5.5 cylinders. any ideas anyone.
 

·
Registered
Joined
·
346 Posts
is the dist and rotor lined up right i remember when i did my cap i keep on puting on cyl 3 insted cyl 1. something to check hope this helps.:shrug:
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top