Turbo Dodge Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
I haven't been able to figure out why my Daytona has such erratic idle patterns. Most times it's fine but then I'll pull up to a light and it will be idling at 2200 for no apparent reason. Sometimes it will come back down, sometimes not. Then maybe at the next light it will be fine. Sometimes when I start it in the morning idle comes down to 900, sometimes it will shoot up to 2200 within a minute. Sometimes it's more like 1500 or 1600. It does seem to be happening more now that it's warm outside, but I'm not sure if it is a coincidence or not. There are no fault codes or anything. only other observance that I can think of is that it only gets 23mpg.

thanks!
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #3 ·
I replaced the O2 sensor a few months back, and the profile just doesn't seem to match the IAC. I mean it's obviously not stuck; there wouldn't be any mode of failure that I can think of that would make it have a mind of its own other than a intermittent connection, but all the connections appear to be ok.

I did find one problem though - in my infinite wisdumb I must have timed it with the coolant sensor connected. When I checked time it was fine when connected but then it jumped down to 4 degrees when I disconnected it! I'll take it out for a drive today to see how it did.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top