Turbo Dodge Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
997 Posts
Discussion Starter · #1 ·
Blew my turbo about 2 months ago and my car has been sitting in the garage waiting for me:mad:

I got some TI retainers and new lifters from Rick D. (thanks 4 Connect Jackson) about 4-5 months ago that I have been waiting to put on. Anyway, I got the head pulled and I ran into some interesting discoveries. First thing is the bottom of the head has an area that looks to me like it was professionally plugged then machined. I could be wrong, the picture shows the area i'm talking about above the upper right hole. Is this factory? Secondly, the head gasket was metal, I think 4 layers. Is this factory or a aftermarket unit? Can I reuse it if it is indeed a cometic? Lastly, there was a three wire plug coming out of the block in between cylinders 2 and 3 that was cut-off at the end and not connected. It was tied:eek:to the turbo coolant return line, do you know what this is?

To my suprise the head seems to be in very good shape!:D Both cams look good, all the rockers/rollers are in good shape(no flaking or wear). There is some minor wear/grooves in one or two of the cam journals in the head. What is the fix for this? There are no caps to cut and re-grind/bore/hone. The head is at the machine shop now being cleaned, checked, cams polished, etc.. Machinist said the wear was small and that he would measure the bore to make sure everything was in spec and then he would clean it all up. Also, I wanted to replace the valve seals while i was at it, is there an aftermarket valve seal that is cheaper than stock? Should I just go ahead and get new valve guides while im at it, even though they look fine? Should I just replace the exhuast side?

Sorry for the long post and all the questions! Any help would be GREAT thanks!!!!!

 

· Registered
Joined
·
4,874 Posts
Sounds like they fixed the leaky plug thats always a problem. And you have what sounds like a cometic HG. Clean it up really good, and spray it with copper gasket spray and you should be good. And the wire your talking about is most likely the knock sensor. You want that hooked up. lol
Hope that helps, if not call the TIII tech hotline, he can answer any question you have :thumb: lol
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top