Turbo Dodge Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
726 Posts
Discussion Starter · #1 ·
i turn the ignition on and hear the pump or whatever humm like normal, the valve in the rail sprays a couple feet in the air when pushed in. the car will start with gas or starting fluid in the top i/c hose, but the engine dies after its used up. what could be causing my injectors not to work? i just put this engine in and i'm wondering what could be wrong, it has no emmisions stuff on it and i think all electrical is plugged in, and vaccuum lines the few i have might be wrong.
 

·
Administrator
Joined
·
25,735 Posts
Power to the injectors is on the DG/BK wire from the ASD relay.
Locate the underhood diag connector and with the key on/ engine off ground the DB/YL wire, this will actuate the ASD and you can check power, if power is present the problem is on the control side(ground) of the injectors.
Any fault codes set?

 

·
Registered
Joined
·
44 Posts
you really need to get a guage on the shrader valve and check your fuel pressure. check it when you just turn the key and prime and while you are cranking. then watch to see if it falls. you need atleast 30psi . even tho you hear the pump and have fuel it may not be enough. if all is correct you have an issue with your injectors. pep boys has noid lights, for $20 i think, that you can plug in to see if injectors are firing
 

·
Premium Member
Joined
·
9,110 Posts
even with low fuel P he should get it running... and if its spraying in the air he should have at least adequate fuel P to start it

injectors arent firing.. its electrical.
 
1 - 4 of 4 Posts
Top