Turbo Dodge Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
I took a 89 Omni that was fuel injected and put in a older motor that has the 4 bolt crank instead up the 5 bolt in the 89 and I put a B&m supercharger on the the older motor with a 4412 2 barrel Holley carb with 7.5 power value and 70 size jets. I left the factory wiring in the car taped back the plugs and wires I didn’t need. My peck timing was 36degrees at 3800 rpm but playing it safe I set the timing to 25degrees at 3800rpm. When I’m in Fifth gear and I lay into it after about 3 seconds it starts to miss and sputtering I got my fuel pressure regulator set to 6 psi. Any input will be a great help and thank you.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #3
I have an air fuel ratio gauge on order seems to be fine in first second and then when I go up a steep hill third fourth and fifth it will skip and sputter but only in the high rpms
 

·
Premium Member
Joined
·
9,006 Posts
not much to go on here but my initial thought is lack of fuel flow, pump, filter, lines..
but could also be spark not adequate for the high-load situation

once yu have yur a/f gauge on we'll know a lot more
 

·
Registered
Joined
·
54 Posts
Discussion Starter #5
Ya I use that the stock electric fuel pump with a regulator though about turning up to like 7 or 8 psi
 

·
Registered
Joined
·
54 Posts
Discussion Starter #6
The only other thing that I do not have hooked up is the map sensor I wasn’t sure if I needed that seems how I converted it back to like a old school set up or do I need that hooked up to fake the computer
 

·
Registered
Joined
·
54 Posts
Discussion Starter #7
Can anybody tell me what this round plug is closest to the head on the intake of the supercharger I would assume it is a pressure valve of some sort but I can’t seem to find any information on it
 
1 - 8 of 8 Posts
Top