Turbo Dodge Forums banner
1 - 7 of 7 Posts

·
Administrator
Joined
·
25,743 Posts
If problem started after the thermostat was installed you probably have air in the system and it is lodged in the heater core which is common.

With the engine cold see if you can remove the hex plug in the cylinder head behind the t-stat housing, it is an 8mm hex.

Here is the proper drain and refill procedure.



 

·
Administrator
Joined
·
25,743 Posts
You stated the problem was not present until the T-Stat was replaced, is this correct?
You are still looking for answers and have not bled the system yet?

Start the car, allow it warm to normal temp, feel the 2 lines to the heater core, are they...
1)Both Hot
2)Both Warm
3)Both Cold
4)One Hot/One Cold

Backprobe the CTS connector with a digital voltmeter with the engine fully warmed up and read the voltage.
Does the cooling fan cycle on/off by itself if you leave the engine run @ idle?

 

·
Administrator
Joined
·
25,743 Posts
No he stated the problem became present when he PULLED the T-stat OUT!. The OP needs to clarify if he even has a T-stat in the system. The heater won't work if the t-stat isn't in there.
That is what I am trying to get at....
Is the engine reaching operating temp?
 

·
Administrator
Joined
·
25,743 Posts
1)The only 2 hoses I am concerned with at this moment are the 2 at the heater core, are they both hot?
2)You mentioned the T-Stat flange was rotted away, that would allow coolant to bypass the T-Stat and the engine run cooler.
What is actual engine temp?
3)Is the coolant full?
 

·
Administrator
Joined
·
25,743 Posts
The OP states that the heat worked great until he removed and re-installed the T-Stat.
My experience tells me if something was fine before and not fine after it is usually related to something that happened during the repair.
 

·
Administrator
Joined
·
25,743 Posts
I agree, anything can happen at anytime.
He has to perform the work and let us know the results.
 

·
Administrator
Joined
·
25,743 Posts
i thought was odd with the ac button out the rad fan is on but the heater fan does not come on
Confused...
Are you saying the blower motor inside the car is inop?
 
1 - 7 of 7 Posts
Top