Turbo Dodge Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
I have an 85 Laser XT. For the most part the car is in incredible condition. 65K miles, garage kept. But it has some issues I'd like to run past you guys.

First, let me say I don't know a lot about working on engines. I rely on my mechanic who is often too conservative. Most of the time conservative is a good thing in car repair, but not really in this case.

The car has 3 problems that may or may not be related:

1. Engine idles pretty rough. The rpms seem to waver abruptly and the car vibrates like a bed in a motel room. My mechanic said this was normal for a 2.4 Turbo. He said it's either doing that or dead.

2. If the AC is on, and the engine is idling (say sitting at a stop light), the engine will begin to step up the rpms higher and higher until I cut it or start moving again. If the AC is off, it doesn't do it. BIZARRE.

3. Last is how sluggish it is off the line. Let's just say there's no way I could drag this thing. I've not tried yet, but the car feels as though if I were to floor it, the engine would sputter and die. If I give it a little goose from a stoplight, it will lose power, the engine will sputter and finally begin to accelerate. Very annoying rolling around in a T-top red turbo vehicle and have the car act this way. :-D
Perhaps related to this is how much I have to dig into the gas to get it moving on a hill like my driveway. Even being an automatic, if I don't jump on that gas pretty quick, it'll roll down the hill backwards before it starts to move up the hill. Even worse trying to reverse up hill.

All that said...once she's moving, she MOVES. It's the getting going that is troublesome. :-D

Any thoughts you could pass my way would be greatly appreciated!

Thanks!
Matt
 

·
Registered
Joined
·
51 Posts
Try changing your tps(throttle position sensor) and your iac(idle air control valve)while doin that make sure your vacuum lines are in good shape and no leaks. I also want to add that running cheap gas in these cars is. Not a good thing and they run like crap when you do.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #3
Thanks...I'll pass that on to my mechanic. Do you think replacement plugs, plug wires, and some injection cleaner would help?

As far as gas goes. We tried 89 octane in it ONCE. Never again! That thing was ticking and knocking like crazy! Only 93 from now on! :-D Usually get that from Sheetz, by the way.
 

·
Registered
Joined
·
1,488 Posts
Are you getting any codes? Check engine/power loss light on?
 

·
Registered
Joined
·
60 Posts
Discussion Starter #5
Nope...no check engine light or anything like that. Unless the light is burned out or something. I'll have my mechanic hook the diagnostic to it and see if it's coding anything.
 

·
Registered
Joined
·
1,400 Posts
There is one area that you should also check, ( I found this out on one of my own cars ) Between the engine and transmission there is a coolent line multi T which is activated with vacum it's part of the A/C system, It's a valve that closes and opens when your A/C is on and off by the controls on the dash,There is a vac line attached to it, see if thats leaking at the thing that the vac line is hooked up to. Mine was I zip straped the multi T open and plugged the vac hose and my vac on turbo guage was better and funny low idle issue went away.
 

·
Administrator
Joined
·
24,989 Posts
An 85 Laser will be a 2.2L so why is this in the 2.4L section?
 

·
Administrator
Joined
·
24,989 Posts
My bad! Sorry!
No need to be sorry, I am looking out for you.
The reason I am asking is because I want you to get the proper help for your problem and some people like me did not even know this thread was here until I started checking the forums.

I can move this thread for you if you like.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #11
No need to be sorry, I am looking out for you.
The reason I am asking is because I want you to get the proper help for your problem and some people like me did not even know this thread was here until I started checking the forums.

I can move this thread for you if you like.
Thanks, man....so which forum does this move to? I just took another read through the forum titles and I still can't figure out which one. They all seem so specific. And I dared not put in the one that sounded like it had to be an emergency! :)
 

·
Administrator
Joined
·
24,989 Posts
I am going to move it to the Help section.
You have a car that will not run so that is an appropriate spot.

Also, reading about your problems you need to verify all basics are correct...
Cam/Ignition Timing
Fuel Pressure
Ignition System
Vacuum System
Air Intake and Exhaust System

Did you say the Power Loss Lamp was inop or you were not sure how to check for fault codes?
 

·
Registered
Joined
·
60 Posts
Discussion Starter #13
I am going to move it to the Help section.
You have a car that will not run so that is an appropriate spot.

Also, reading about your problems you need to verify all basics are correct...
Cam/Ignition Timing
Fuel Pressure
Ignition System
Vacuum System
Air Intake and Exhaust System

Did you say the Power Loss Lamp was inop or you were not sure how to check for fault codes?
Technically, it does run. Just not as well as I'd like...and I don't need it to drive to work tomorrow. :)

I don't notice any lights coming on when this happens. So, my only thought was perhaps the lamp was burned out and it was coming on but I didn't know it. I do not know how to check for codes. I know there are tricks with turning the key on some vehicles, but wasn't sure about this one.

Thanks!
 

·
Administrator
Joined
·
24,989 Posts
1 - 15 of 15 Posts
Top