Turbo Dodge Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
760 Posts
Discussion Starter #1
Okay, my brand new Accufab universal regulator does not work. Basically the regulator gets fuel (from 255 Hi Press. Walbro) into its center port however it stops there and even with the adjustment knob pulled out, ZERO fuel exits from the return(off set port) and its shows ZERO on my brand new autometer FP gauge. I pulled it apart and verified that the return hole is not blocked and neither is the FP gauge port(no fuel there) using compressed air, so this means the spring is not lifting from its seat? Direct FP from the fuel pump BURIED my test 100psi gauge, so the fuel is there, and more than enough to push some fuel into a bucket I put under the return port.

I give up, what now? New spring? Accufab states its never had this problem with the regulator doing this before but will look at it, which will cost me storage time at my shop since it must be sent to them. . . I want to finally drive it home :eek:

I've talked to Chris W. about this, but am not sure he has the Accufab rebuild kit which should include a new spring/seat/gasket, is this the fix I'm looking at?

I'm so frustrated with it now :bang head
 

·
Registered
Joined
·
907 Posts
Where did you buy the regulator? If it was one of our vendors im sure they would be more than happy to make an exchange.
 

·
Registered
Joined
·
760 Posts
Discussion Starter #4
Geoff said:
Where did you buy the regulator? If it was one of our vendors im sure they would be more than happy to make an exchange.
From TU, but the exchange will take days and unfortunetly I don't have the storage time at the shop :eek: Can somebody please send me the AFPR instructions and how sensitive the adjustment is? Thanks for any help!
 

·
Registered
Joined
·
632 Posts
I had a different issue with the accufab, it adjusted fine, but didnt raise pressure with boost. Caused massive detonation, huffed the HG, and wounded a forged slug. I have lost all faith in accufab. Will more than likely rebuild it, test it and sell it to someone that wants one anyway.

Hope you get it sorted out, those regs scare me now, to much invested in this motor to pop it due to a friggin reg.
 

·
Registered
Joined
·
760 Posts
Discussion Starter #7
TU is sending me a new spring ASAP as that seems to be the problem? You would think 100psi+ of fuel pressure would be able to easily unseat it!
 

·
Banned
Joined
·
1,471 Posts
91DSX said:
TU is sending me a new spring ASAP as that seems to be the problem? You would think 100psi+ of fuel pressure would be able to easily unseat it!
Hi Roger,

Now that you have corrected your AFPR issues by reversing the input/output lines could you PLEASE send us back the internal parts that we overnighted to you for FREE. We have a disassembled AFPR that we can not use sitting on our shelf because you still have all the guts to it. We have tried several times to contact you with PM's with no response.

Thank You!
 

·
Registered
Joined
·
760 Posts
Discussion Starter #9
Chris W said:
Hi Roger,

Now that you have corrected your AFPR issues by reversing the input/output lines could you PLEASE send us back the internal parts that we overnighted to you for FREE. We have a disassembled AFPR that we can not use sitting on our shelf because you still have all the guts to it. We have tried several times to contact you with PM's with no response.

Thank You!
Oh man, so sorry Chris!!! I am sending it tomorrow express, I realized I kept it packaged up because I needed your new address(waited for you to get back from the trip) and I forgot about it until now, I got the PM's too, again much apologies. Please send me an e-mail with ANY cost involved in sending it to me plus any other costs you deam necessary, for anyone reading this Chris helped me out BIG TIME as you can see, stupid me just plain forgot! :(
 

·
Banned
Joined
·
1,471 Posts
91DSX said:
Oh man, so sorry Chris!!! I am sending it tomorrow express, I realized I kept it packaged up because I needed your new address(waited for you to get back from the trip) and I forgot about it until now, I got the PM's too, again much apologies. Please send me an e-mail with ANY cost involved in sending it to me plus any other costs you deam necessary, for anyone reading this Chris helped me out BIG TIME as you can see, stupid me just plain forgot! :(
No problem Roger. I PM'd you our new address a while ago but you never responded. Here it is again:

Turbos Unleashed, Inc.
24453 South 194th Street
Queen Creek, AZ 85242

I wasn't sure if you were getting my PM's so decided to post. No compensation is required and please don't pay for express. Just ship it out so it get's here within a couple of weeks. :thumb:

THANKS!

Chris-TU
 

·
Banned
Joined
·
1,471 Posts
??????????

91DSX said:
Oh man, so sorry Chris!!! I am sending it tomorrow express, I realized I kept it packaged up because I needed your new address(waited for you to get back from the trip) and I forgot about it until now, I got the PM's too, again much apologies. Please send me an e-mail with ANY cost involved in sending it to me plus any other costs you deam necessary, for anyone reading this Chris helped me out BIG TIME as you can see, stupid me just plain forgot! :(
Chris W said:
No problem Roger. I PM'd you our new address a while ago but you never responded. Here it is again:

Turbos Unleashed, Inc.
24453 South 194th Street
Queen Creek, AZ 85242

I wasn't sure if you were getting my PM's so decided to post. No compensation is required and please don't pay for express. Just ship it out so it get's here within a couple of weeks. :thumb:

THANKS!

Chris-TU
Hi Roger,

It's been over a month now since your post stating that you would be returning the AFPR parts we shipped you OVERNIGHT for FREE back in May. If you will not be returning the parts could you at least pay us for the AFPR and I will send you the remaining parts.

Thanks,

Chris-TU
 

·
Registered
Joined
·
1,744 Posts
Goodness, everything suddenly went quiet!
 

·
Registered
Joined
·
760 Posts
Discussion Starter #13
Chris W said:
Hi Roger,

It's been over a month now since your post stating that you would be returning the AFPR parts we shipped you OVERNIGHT for FREE back in May. If you will not be returning the parts could you at least pay us for the AFPR and I will send you the remaining parts.

Thanks,

Chris-TU
Chris, I am paypaling you the cost for the regulator and shipping tonite, however do not send the regulator to me, I will send the parts as I have completely forgotten about this :( *IF* you get the parts in around a week (sending it today, put a big sticky on my car, lol), then you can refund the cost of the regulator to me once the parts arrive, if they don't arrive in a week, you keep everything.
 

·
Registered
Joined
·
760 Posts
Discussion Starter #14
John B said:
Goodness, everything suddenly went quiet!
This is between the vendor and myself thanks, your comments aren't needed :rolleyes:
 

·
Registered
Joined
·
2,752 Posts
i also have an accufab unit, from TU, works fine.

MATT's experience desribed above should be proof that anyone contemplating new fuel components, or, fooling with boost and or fuel, would be smart (and safe) to run a wideband a/f ratio check (or EGT measurement) in parallel w/ any mods to fuel and/or boost.

it's way too easy and cheap to check a/f ratios, and way too difficult and expensive to replace pistons.
 

·
Registered
Joined
·
760 Posts
Discussion Starter #16
BTW I discovered at the time, but forgot to update this thread, I had the ports crossed, that caused my issue! The regulator is working perfectly :D
 

·
Banned
Joined
·
1,471 Posts
Got It!!!

Thanks Roger! :thumb:

It arrived last week. I've been so busy that I forgot to post a follow up message. Now to get all the parts together so we can toss it on our race car.


Chris-TU
 
1 - 17 of 17 Posts
Top