Turbo Dodge Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
I hope someone can help me with this I am at my wits end. I recently converted my 87 Charger to Tll. While running in boost, 14 psi it misses, ONE time while driving it ran very well pulling hard w/out missing. I have replaced all the normal tune up parts but that did not seem to help, no change at all. When idling the engine nearly stalls and narrow band afr gauge go's blank and lights up again when the engine picks back up. I bought a new BWD brand hep, first one did not work at all, instant code 54. The replacement one was installed today, car would hardly run, although no code. Installed my old MOPAR hep and it runs, although poor. I have some mods they are fmic, larger throttle body, 2 1/2 exhaust with short muffler and FM 475 cam. Cam timing has been verified using method described by naj. Engine pulls 15 in of vacuum @ idle. HELP
 

·
Super Moderator
Joined
·
6,975 Posts
at this time, i would reccommend checking compression in all 4 cylinders.
 

·
Premium Member
Joined
·
9,043 Posts
While running in boost, 14 psi it misses, ONE time while driving it ran very well pulling hard w/out missing.
and ever since then it has had a a boost stutter / misfire ?
that suggest a vacuum hose popped of the MAP or FPR ;
at higher boost levels, you need to add tiny hose clamps or zip ties to the vac lines to keep them from popping ..
or there is a crack in a (old OE hard plastic?) vac. fitting/hose that is bigger at high psi..
condition of vac lines & fittings ?

you need to add more detail her as to what is happening during the 'issue' ... what is A/F ?
if you slightly back out of throttle , to 12 psi , how does it run ?

I have replaced all the normal tune up parts but that did not seem to help, no change at all. When idling the engine nearly stalls and narrow band afr gauge go's blank and lights up again when the engine picks back up.
this idle behavior is not entirely uncommon, even a stock-ish TI/II has a pretty drastic idle AFR hunt and accompanying idle rpm hunt... pretty aggravating sometimes %)
but iif its nearly stalling before catching itself then there is something wrong .. any codes ?
 

·
Registered
Joined
·
35 Posts
Discussion Starter #7
Since the conversion it has never ran well, when I first stared it it ran smooth when cold as the engine warmed it would begin to idle poor and if I opened the throttle the engine would backfire and shake, and make a popping noise in the intake. swapped a different used coolant temp sensor and that seemed to help, but I don't think that was the problem. The idle thing is puzzling, it is almost like you turned the key off, the tach instantly drops and returns just as quick. No codes. All new vac hoses, none missing. I believe this is an electrical issue, although at this time I am just confused.
 

·
Administrator
Joined
·
24,996 Posts
I just have to say that backfiring thru the intake is always caused by a Timing Issue or an issue with Firing Order, Cracked Cap, Induced Voltage into a Secondary Ignition Wire.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #9
I just have to say that backfiring thru the intake is always caused by a Timing Issue or an issue with Firing Order, Cracked Cap, Induced Voltage into a Secondary Ignition Wire.
The cap and wires are all new I replaced them trying to fix this issue, no change The hep thing is confusing to me, 2 bad ones? BWD brand ones are poor quality, sure wish I could buy a new MOPAR one, they are on backorder. I have checked the cam timing a couple of times using your method and with a timing light with timing set at zero The problem seems worse a higher fuel pressure, I rased it to 60 psi static to make sure I was rich enough, at 55 psi it is better but still poor and the idle issue is still present
 

·
Administrator
Joined
·
24,996 Posts
First off, when installing a new HEP DO NOT place any sharp bends in the wiring or try to bend it down the side of the distributor as Chrysler had it or you will damage the internal wiring which is extremely fragile.
The problem you are describing would not be with the HEP but with the distributor or shutter blades.

You do not want to run higher fuel pressure, rail pressure will increase by itself with boost.

What are your plugs gapped at?
Are you sure your firing order is correct?
Are the wires all the way in thru the cap?
Have you verified the ignition system is capable of a minimum of 25 KV?
 

·
Registered
Joined
·
35 Posts
Discussion Starter #11
First off, when installing a new HEP DO NOT place any sharp bends in the wiring or try to bend it down the side of the distributor as Chrysler had it or you will damage the internal wiring which is extremely fragile.
The problem you are describing would not be with the HEP but with the distributor or shutter blades.

You do not want to run higher fuel pressure, rail pressure will increase by itself with boost.

What are your plugs gapped at?
Are you sure your firing order is correct?
Are the wires all the way in thru the cap?
Have you verified the ignition system is capable of a minimum of 25 KV?
All you have recommended are correct, shutter wheel is nice and tight, plugs are gapped @.028. Plug wires installed correctly. My complaint with the BWD hep is the cover fits poorly as the wires don't set in the small groove in the bottom part of the hep creating a situation to EASILY to pinch the wires. One thing that you have mentioned is the 25KV test how do you go about testing for this?
 

·
Administrator
Joined
·
24,996 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #13
Mopar HEP #4886069AA
$83.01 + shipping from wholesalemopar.com.

Great Neck/Adjustable ignition spark tester (25069) | Ignition Tester | AutoZone.com

Also be sure all your engine grounds are connected, secure, clean, especially intake to firewall.

Be sure you do not have ignition wires running parallel to each other or low voltage wiring running near/parallel to high voltage lines.
Thanks for the info, called wholesalemopar last week, hep is on backorder, he told me he has no idea when I wiil be able to get one, I will try the ignition test will post my results
 

·
Registered
Joined
·
35 Posts
Discussion Starter #14
Thanks for the info, called wholesalemopar last week, hep is on backorder, he told me he has no idea when I wiil be able to get one, I will try the ignition test will post my results
Thanks naj I remrmebered I had tester similar to the one you described, installed it and started engine. Spark was stong but not steady. Instead of snap snap snap it was more like snap snap pause snap pause. I am going to look at this curcuit in my service manual to see if there are any poor connections although at this time I am thinking hep, any thoughts on this from you? Thanks again
 

·
Super Moderator
Joined
·
11,773 Posts
why do you have the plug gap so tight ?

sticker on hood calls for .9mm or .35-6 inch

what plugs are you useing ? - sticker calls for champion rn12yc but rn9yc (colder) is best
 

·
Registered
Joined
·
102 Posts
i feel dumb asking this but whats a hep check the pins going into the computer when i did mine car rand liek crap and one of the pins going in the computer wasnt makeing contact i had to take the computer apart and hold it with my finger while i pushed the harmness in took me weeks to find that
 

·
Registered
Joined
·
1,488 Posts
Quick question? Did you change the pinouts at the LM connector for the Turbo II module?
 

·
Registered
Joined
·
1,488 Posts
It is for sure a GLHS module? if anything else there are pins youhave to swap from the red connector and vice versa
 

·
Registered
Joined
·
35 Posts
Discussion Starter #20 (Edited)
i feel dumb asking this but whats a hep check the pins going into the computer when i did mine car rand liek crap and one of the pins going in the computer wasnt makeing contact i had to take the computer apart and hold it with my finger while i pushed the harmness in took me weeks to find that
Thanks for your reply, the hep is the small electrical component under the distributor cap. When you had the pin problem did you get any codes?
 
1 - 20 of 24 Posts
Top