Turbo Dodge Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter #1
Looking to see if anybody has ran into this problem, I replaced my 46mm stock throttle body on my 87 Shelby CSX with a 52mm throttle body and now my car idles around 2500 rpm. My car ran perfect prior to this swap. I thoroughly cleaned the used T.B. I purchased, reused the T.P.S. Sensor and A.I.S. Motor from my oem T.B. Installed a new gasket and now it will not idle down below 2500 rpm even with the idle set screw backed all the way out, I also read NAS sticky on how to reset the A.I.S. Motor and nothing has changed, I rechecked ALL my NEW vacuum lines installed last year and found no problems. Anyone have an idea on what could be causing this?
 

·
Administrator
Joined
·
24,686 Posts
One of three things happened.
1)You increased airflow enough that the Controller/AIS cannot bring the idle speed down.
2)The AIS used in the 52mm TB is different than the AIS used in the 46mm TB.
3)The throttle plate is stuck open either due to a warped plate or the throttle cable is holding it opened.
 

·
Registered
Joined
·
175 Posts
Discussion Starter #3
I consulted with Boost Button (he has been doing my programming for awhile now) prior to doing this swap and he said I would most likely not have to change any programming. I was told the A.I.S. motors were the same, the throttle cable is definitely long enough, I have not checked for a warped throttle blade yet, I think I would of caught it when I cleaned it. Hopefully I get it figured out soon the Woodward dream cruise is on the 15th. Lol!!
 

·
Administrator
Joined
·
24,686 Posts
Other than what I posted the only other things that would cause a high idle are...
1)AIS is not moving
2)Large Vacuum Leak.
 

·
Registered
Joined
·
175 Posts
Discussion Starter #5
I called Autozone and O'Reillys and had them both check the part number for the AIS motors for my OEM T.B. and a 1987 caravan with a 3.0 which is what I am assuming this 52mm T.B. Came off of and yes both Autozone and O'Reillys said they are different part numbers. Hopefully that is the problem.
 

·
Registered
Joined
·
705 Posts
The AIS motors have different sized tips and the smaller one won't cover the hole in the larger throttle body so it doesn't shut it down to idle. Sometimes they will unscrew completely and come apart.
 

·
Registered
Joined
·
175 Posts
Discussion Starter #9
The T.B. I bought didn't come with a tps or ais, pretty much stripped down. I'm going to Autozone today to buy the correct one. Another $60 Oh Well!! I am pretty confident this will fix my problem. Thanks Everyone for your help!!!
 

·
Registered
1989 Daytona Shelby 2.2 TII
Joined
·
279 Posts
i know its 4 years later, but did that fix the problem?? thanks
 

·
Registered
Joined
·
175 Posts
Discussion Starter #11
I had to go back to the original Throttle Body and that fixed it. I found out later that if you plan on going with the larger T.B. you have to do some port work to the intake which I wasn't willing to do.

Sent from my GM1917 using Tapatalk
 
1 - 12 of 12 Posts
Top