Turbo Dodge Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
651 Posts
Discussion Starter #1
Blueball, turbogod, and I stopped into FWD for some dyno time today to get ready for the Mopar event at Houston Raceway Saturday and Sunday. Both Blueball and Turbogod's Omni's had a fuel system issue in the upper RPMs. Even with Blueball's fuel issues he pulled a 335 HP run. Steve had a weld break on his custom made fuel rail which houses his 4 extra injectors causing a major spilage on the dyno. The CSX ended up pulling off 344 HP at 413 Ft torque. It's off to race tomorow!!!!!

Her are some pics from today:





 

·
Registered
Joined
·
651 Posts
Discussion Starter #2
I probably won't have internet access to update the track event until I get back home Sunday or Monday.
 

·
Registered
Joined
·
651 Posts
Discussion Starter #3 (Edited)
Hey guys!

Just got back from the trip and very tired. This was the longest 2 days I've had in a while.:nod:
Kevyn's fuel delivery problem on the little red Omni was due to the epoxy breaking loose on the magnets in the in-line Aeromotive fuel pump. My buddy Thomas and Kevyn tore it down to find the problem and fixed it in time to race a little this weekend.
My IC hose blowing off at the turbo and the fuel pump not working correctly lead to ALOT of frustration as well as the 1/4 mile Houston Raceway not allowing me back on the track after loosing my first ever bracket run. So, I only got 2 passes out there 12.3 blowing hoses and 12.01 @ 114 in the bracket race event. After me getting very agrivated at driving 260 miles and getting 2 passes, Cindy, James, and Rick was nice enough to lead us to their local 1/8 mile track which was a big "Hurry up and Wait" game but after quite a few issues we ended up with some best runs to date.

My CSX slammed me helmet into the head rest when it pulled a 1.72 60' while running a 7.4 sec 1/8th at 96 MPH with 29-30 psi boost and leading to notice I have maxed out the 52 pph injectors and need to definately go to 72's.

After all the troubles with the fuel system, Kevyn's red Omni at the end of the night ended up with a 7.19 sec run at 99 MPH on 22-25 psi boost!!!!!Everyone was quite intrigued at the 2 little cars:thumb:

After I rest a little, get the car off the trailer, take Kevyn's Ram Charger to him, and spend some time with the family, I will try to get some video down of the events. Wow, will be a long day!
Thanks to Cindy, James, and Rick for ALL their help and support at FWD Performance to make this weekend happen!!!!!!!!!!!:hail:
 

·
Registered
Joined
·
806 Posts
Since your suppose to be on your way here I'll put in a correction for ya. The said magnets had opposite poles Im thinkin.And when we bonded them back in,they went to opposite side they were originally in. The wires were put back on the original way and that results in a pain in the ass. I will conquer Hoiuston one day!!:smashfreakB:
 

·
Registered
Joined
·
4,433 Posts
Yes, it was great having you guys come down!

The 1/8th mile track is pretty nice, isn't it?
I bet the 2 TD's were the only two cars under 50K there that night!! There was some really nice and fast cars running.

Kevin, considering the car hasn't ran in years, the little omni did awesome. And 7.19 at 99mph in the 1/8th is pretty dang fast. all in all you shouldn't be disappointed.
Chris, awesome street car for sure! Looks nice, runs nice, and is still very dependable. great job:thumb:

Too bad Steve had some issues, I would have loved to see his car run.
later,
Cindy
 
1 - 9 of 9 Posts
Top