Turbo Dodge Forums banner
1 - 9 of 9 Posts

· Registered
Joined
·
404 Posts
Discussion Starter · #1 ·
I tuned my S60 mini w/ 3" exhaust, G-head, W/A intercooler, Stage5 cal, etc. to 20psi and have been running strong with it for a few days. Today, I was coming home from getting gas (double checked the receipt, did get premium from Chevron as I always do), punched it... it barely got to 16psi and was lacking power and very laggy and studdery. I pulled it in the shop, was idling like crap. Pulled all the plugs... cylinder #4's plug looked like somebody took a hammer to it! Was bent over all the way! Oil all over in teh cylinder... put a differnt plug in, and now its got some bad knock.

Ill be pulling the engine and building it either way, but was curious... WTF DID I DO WRONG?!?
 

· Registered
Joined
·
4,660 Posts
detonation, was your engine light blinking? Too much timing for the 2.5 to take is my guess. Need to dial back the timing on these.
 

· Registered
Joined
·
901 Posts
I was reading on another post you where running stage 5 cal. You told you got af ratio of 12.1 @ 20 psi of boost...in my mind it's too lean. You need very good octane to run 12 AF...on pump gas you need to be richer..it will cool combsstion chamber and reduce detonation chance.

thank
 

· Registered
Joined
·
1,012 Posts
That really doesn't look like detonation to me... have you pulled the pistons to see what the ring end-gap looked like?
 

· Registered
Joined
·
1,012 Posts
wow, sorry - old thread
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top