Turbo Dodge Forums banner
1 - 18 of 18 Posts

· Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 88 shelby z having trouble with idle i hav done all the tricks temp sensor reset ond so on also have lots of smoke out the tail pipe didnt have that much smoke till put anti freeze in insted of water help!
 

· Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
thanks every one I'll try some off this stuff dont have compression num. but will try to get those I'm kinda new to the 4cyl turbos so any help would be greatly appr. the smoke is pretty much white with just a haze of blue from time to time and it dont smoke all the time
 

· Registered
Joined
·
1,157 Posts
Is it running smooth or rough?Since I really don't know much about mechanics, maybe you should throw and oxygen sensor at it. That seems to always be the first thing to throw at a running problem :thumb:
listen 22dodge, leave me out of your stuff.. If you want to help someone, do it! If your not here to help GTFO!
 

· Registered
Joined
·
1,157 Posts
running rough and smoking to me means the motor is getting correct input from the computer... the first thing i think of when i hear something like that is a bad map or o2 sensor. Since it is OBVIOUS you know it all you know for a FACT you wouldnt just dive under the car and change it out when you can probe the wires and see what the voltage output is and determine if its bad or not. If you want to compare wang sizes i suggest you go bugging someone else because i'm not just your average joe ;)
 

· Registered
Joined
·
7 Posts
Discussion Starter · #11 ·
look I dont know what all that shit is about im just tring to get advice on some problems im not in here trying to cause trouble just want advice sorry if i pissed some one off if you dont want to help thats fine if your on here to just blow shit stay the **** off
 

· Registered
Joined
·
231 Posts
on my old saturn sc2 i had the same problem and it turned out to be a BAD headgasket leak. When i pulled the head to put a new gasket in there was still some coolant sitting on top of the pistons. Now my guess is thats what the smoke is is coolant and your injectors could be getting fouled from the coolant being in the cylinder, im not 100% sure so no oe jump down my throat but feel free to correct me if im wrong
 

· Mr. Moderator
Joined
·
8,952 Posts
Sounds like a headgasket with the white smoke.
Check the oil. If its kinda like a milkshake and very liquidy then you most likely gotta head gasket issue.
Could also be a bad turbo. Is your turbo making any wistling noise when runnin?
Take the hose off the turbo that goes to the airbox. THen wiggle the shaft of the turbo
If there is excessive play (move about a half inch each way) then it very well maybe a turbo issue.
Blue smoke = oil and most the time oil coming out the back is from the turbo.
I would definitely also do a compression check.
Does it run rough?
You have been asked multiple times on how it runs. I would answer the question to help you with diagnoses.
Good luck
Q
 

· Registered
Joined
·
7 Posts
Discussion Starter · #15 ·
runs good from 1200 rpm up its just at idle the smoke has almost stopped the smoke is a whitish blue a buddy said the seals in the turbo might be bad the oil looksgood no milky look sorry about gettin shitty was a bad day just venting thanks everyone for your help it putting out verry little smoke kinda smells like oil
 

· Registered
Joined
·
4,660 Posts
look at the plugs- if there is oil there then you could have bad valve seals or rings are shot. If the plugs are clean drop the downpipe and look for oil inside the swingvalve.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top