Turbo Dodge Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
147 Posts
Discussion Starter · #1 ·
as far as I know there is a relay that turns the onboard amps on right? I'm getting highs but no bass, the speakers all work so it has to be something else. I was told that there is a relay in the drivers side kick pannel but theres nothing there. Theres other relays but no radio amp turn on, and does it make a diffrence what factory Infinity radio I use, I got one out of a 92 Imperial and that works fine.
 

·
Registered
Joined
·
999 Posts
Any radio will work; the relay is controlled by the low-amperage output on the radio (blue with white tracer on aftermarket radios). Do you hear a click when you turn the radio on? If not, are all the fuses good? I can't remember whether or not it's on the same fuse as the radio. Maybe NAJ can help you out with a wiring diagram.
 

·
Registered
Joined
·
140 Posts
You say you replaced the radio... makes no difference, but did you reconnect the single female spade connector behind the radio to ground? The relay won't turn on without that wire grounded.
 

·
Registered
Joined
·
140 Posts
In that case, I would check fuses first - the Infinity relay is usually on another fuse from the radio itself. If that's not it, check the power antenna wire on the posted diagram for 12V with the radio on. If you get power there, next check the relay. If it's good, the only other possible causes are wiring, dead speaker amps, or the speaker choke (power for all the amps goes through it).
 
1 - 7 of 7 Posts
Top