Turbo Dodge Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
hey guys i recently bought my srt-4 and it seems to me like there is a little hiccup/miss at idle...it does it every once in a while...since these things have that loby exhaust note its hard to tell if this is normal or not...to me it doesnt sound too normal but maybe im paranoid...car is an 04 stage 2 w/ toys...does it when theres 23 secs left on video...check it out...

Movie | Flickr - Photo Sharing!
 

·
Administrator
Joined
·
10,120 Posts
is it a stage 3 with toys?

sounds like the coil pack to me, straight up miss fire. Without a heat shield they eat coils and wires. A stage 3 without the heat shield would eat them faster
 

·
Registered
Joined
·
29 Posts
Discussion Starter #4
it is a stage 2 w/ toys and it does have a heat shield...i changed plugs, wires, and coil...it does sound like a misfire right? what else can it be? i need a wideband for this thing but since i just got it i dont have too much money for mods atm...
 

·
Registered
Joined
·
29 Posts
Discussion Starter #5
all right guys i dont want to make a new thread so ill just post it here...i did a 2nd and 3rd gear pull today on low boost and towards 4500 rpms maybe the car felt like it stumbled/bogged/ or just died for maybe 1/2 a sec...it was weird...i tried it again and it didnt do it...i think there is defenetly an issue here...what else can i try? i mean, the car drives fine...i tried plugs gapped to .38, wires, and swapped coils and still the idle doesnt change...car is not throwing any codes...i mean, what else can this be?

oh and another thing...after the pull i came to a stop light and i noticed that the temp gauge went past the half way mark between 1/2 and 3/4...after a couple secs idling at the light it came back down to half...is this normal? i've noticed the needle fluctuates alot...sometimes itll actually go down about the same amount i mentioned above...between 1/4 and halfway mark...
 

·
Registered
Joined
·
3,073 Posts
You say it was at low boost, but that sounds a bit like cutout to me from overboost.

The temp gauge does seem to fluctuate a lot on these cars. Mine never goes past half way though.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #8
overboost? it was 14 psi...why would it do it for a split second and keep going...i mean, its not like i got on it at 1k rpms...i slowly eased into it and went wot when it was fully spooled...
 

·
Registered
Joined
·
3,073 Posts
What modifications have you done to the car?

What reads as 14 psi could very well have been a little higher, and you have overboost shutdown. That is when the computer cuts fuel to keep from exceeding the limit of the injectors, its a safety device you could say. When it happens the engine cuts out for like a second, then comes right back.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #10
What modifications have you done to the car?

What reads as 14 psi could very well have been a little higher, and you have overboost shutdown. That is when the computer cuts fuel to keep from exceeding the limit of the injectors, its a safety device you could say. When it happens the engine cuts out for like a second, then comes right back.
hmm, i see...well, that makes sense...car is a stage 2 w/ toys with an agp wastegate...maybe i should back out the wastegate some since its hitting 14 psi on dial - a - boost 0 setting...i wonder if theres a boost limit per each setting?
 

·
Registered
Joined
·
681 Posts
If you hit overboost, you'd know - in my Shelby Z it's like a dog hitting the end of a leash. Happened once to me - damn sure I won't let it happen again.

Do you have proper fuel pressure on the rail? How is the fuel filter?
 

·
Registered
Joined
·
29 Posts
Discussion Starter #12
dont have a fuel pressure gauge and havent touched the fuel filter since on these cars i think its intergrated into the fpr which is on the fuel canister...should i get a new fpr? anyone know how difficult it is to change?
 
1 - 12 of 12 Posts
Top