Turbo Dodge Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,192 Posts
Discussion Starter #1
I've noticed my A555 has a very distinct, and loud gear whine. It only happens when I'm on the gas. If I let off the throttle, the noise goes away. But if I'm on the gas, it's constant.

I haven't checked the fluid for a while, but have filled it within the last five months.

Car runs/drives/shifts smoothly, so what's causing it?

Perhaps filling it up with Royal Purple trans lube/oil would be a good decision.
 
L

·
Guest
Joined
·
0 Posts
I dont think it will go away immediately. You might have to drive it for hundreds of miles for it to "wear in" again. Just keep an eye on the level so it dont ever run low again:thumb:
 

·
Registered
Joined
·
13,463 Posts
To quote Chris Cliff on another, "my a555 make loud noise" thread. I guess you should start saving for another transmission.

Sorry if my first post was misleading, but most times when it's run low enough that the gears start making noise the damage is done and just a refill won't correct the issue. 5th damage is almost assured with a decent amount of mileage on low fluid and if it's truly loosing oil at such a rate then the trans was most likely driven low for a long period of time and damage has been done to other gears as well.

The other problem will be that a common damage point is for the shaft surface near the thrust washer between 2-3 to be come damaged as well and make it impossible to remove 1-2 and the 1/2 synchro assembly. Be prepared for this if you decide to rebuild this transmission.
 
1 - 5 of 5 Posts
Top