Turbo Dodge Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Hello, my builder is having a clearance problem with the Melling.
I have a 1984 block
A Melling high flow pump

With the parts (pickup) he took from the engine, and the new melling pump he is having a clearance issue. He has the 84 pick up tube, the 84 pan, the only thing that has changed is the pump.

Has anyone had this issue in the past?

Does anyone know how to fix it?

Thanks
 

·
Registered
Joined
·
44 Posts
I have had problems with mellings pumps as well. mostly the clearance on the foot. it moves the pump up and causes it to shear the teeth off the gear and intermediate shaft.
where are you having clearance problems?
 

·
Registered
Joined
·
1,491 Posts
I always tape the pumps holes up, then grind the frontside of where the pump mounts to the block. Sometimes they are just made sloppy or the "casting flash" interferes with the pump mounting flat. Which in turn sometimes causes the distributor to wobble sometimes and it is also the main cause for the oil pump / int. shaft gears to strip out.
 

·
Registered
Joined
·
1 Posts
When using the Melling M118 pump follow the instruction sheet supplied with the pump.
Some blocks require that you grind at the point of interfearance on the pump.
Also the use of the 118S screen is nessary when using the M118 pump
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #6 ·
Thanks for the info, I have him modifying the pump to retest it, if that doesn't work im just going to get a mopar pump and be done with it.
 
1 - 6 of 6 Posts
Top