Turbo Dodge Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Just picked up a 2003 SRT4 with Stage 3 with toys option. The toys option is not being used. Some kind of aftermarket system was being used and was soldered into the PCM, ran inside, and mounted below the radio in the cubby hole at the bottom. It has 3 factory looking connectors still there but no controller/switch panel. It also has a diagnostic port clipped to the wiper cowling in front of the driver.
Problem is, the car 1) won't crank with key(can jump it at the relay or starter), 2) has no power to the coil and probably the fuel pump(crank sensor signal interupted for module), 3) ambient air temp is stuck at -65*(even when jumped, meaning it is interupted also). May have a jumper in the glove box but it doesn't match any of the 3 connectors. Looks like a radio adapter. I have looked at d2mb setups and they are not even close, at least the ones I have seen.
In short, I have a new car that won't run because I don't have a control panel. References to possible solutions would be greatly appreciated.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
Figured it out. Mopar Toys option with factory connectors, missing bezel. Diagnostic connector was fuse box holder for setup.
I was looking at the wrong temp sensor also, there are two. One is ambient air temp mounted in the air tube just before the filter behind the driver headlight. The other one is the intake air temp mounted in the cold side pipe 6" from the throttle body in the short plastic tube. Its sensing element, blue tab, is exposed where the ambient air is totally sealed. Mine was damaged.
 
1 - 2 of 2 Posts
Top