Turbo Dodge Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter #1
Ok guys, here's my next question. My 89 is just getting to old, but she still runs like new. Love that van.. Anyway my tail light started flickering like a candle and eventually went out. I have brake lights, turn signal and emergency's all fine just no tail light. Doesn't seem like it's getting power, not sure. What do you think? Not the bulb, checked. Do I have to take panel off inside to get to wiring and go through all that or is there an easier way? Already been pulled over for it. Just happened about 2 weeks ago.
 

·
Administrator
Joined
·
24,120 Posts
The most common problem is a loose connection in the socket itself.

There are 3 wires in the socket...
1)Gray - Power for Taillamp
2)Dark Green - Power for Stop/Turn Signal Lamps
3)Black - Ground

a)Be sure the socket to bulb connection is clean with no corrosion present.
b)You can use a 12 volt test lamp connected to ground to check for power on the Gray wire.
c)With the bulb installed wiggle the wires where they enter the rear of the socket to see if the lamp illuminates.
 

·
Registered
Joined
·
207 Posts
Discussion Starter #3 (Edited)
So, are you saying if turn signals and everything else works, it's not a power problem? Cause I had someone check it and they said there was no power to it. And they would have to take off panel inside car to get to taillight wiring. Duh, just reread my reply. Of course your not saying that. Obviously, we have to repair grey wire. Sometimes I read to fast. lol
 

·
Administrator
Joined
·
24,120 Posts
No I am not saying that, power to the tail light part of the dual filament bulb is on a separate circuit from the brake/turn signal part of the light, they do share the same ground.

The Gray wire also powers the backup lamp so is the backup lamp operating on the side that the tail lamp is inop?
If so your issue is probably with the socket assembly.

I do not know how to access the socket assembly on an 89 Caravan without seeing it.
 

·
Registered
Joined
·
207 Posts
Discussion Starter #5
I have never had back up lights on that van. And I never bothered with it. So, I can't answer that. We'll see when we actually get to work on it.
 

·
Registered
Joined
·
207 Posts
Discussion Starter #7
Ok fixed but, wires were grey, purple, brown and green. Go figure. We eliminated the connection and ran them straight. So all work's now.
 
1 - 7 of 7 Posts
Top