Turbo Dodge Forums banner

501 - 504 of 504 Posts

·
Registered
Joined
·
101 Posts
My dad bought a 1985 1/2 Chrysler Laser XE new at O'Reilly Chrysler-Plymouth-Dodge in Sierra Vista, AZ when he was serving in the Army. It is white with black side stripes and an oxblood red cloth interior. It was optioned out with a turbo, auto trans, European sport suspension, sunroof, power mirrors, adjustable driver's seat, electronic instrument cluster, 12-button navigator, and the vehicle diagnostic system (with the awesome voice), to a grand total of 15,080. The dealer also installed a set of louvers, but we ended up taking them off the car in the '90s because they were starting to look terrible, and we've regretted it ever since. My dad kept the car, retiring it from daily use in '95, and it looks absolutely brand new today. It was repainted once in '96 and had NOS stripes and emblems installed. It has 155,000 miles on it, and almost every time we have the car at a show someone asks when we had the car restored, or tells us that it looks brand new, or tells us that they remember someone that owned a Laser or a Daytona once and how you don't see them anymore. back in '86, my dad was driving across NM in the middle of the night and decided to see how fast his Laser could go. he it up to 140, but decided not to try for any more speed. I'm tempted to try that again, but I don't want to damage anything. The car is still a special member of the family, and we have duly babied it.
 

Attachments

·
Registered
Joined
·
42 Posts
Re: Chrysler Laser thread!! POST PICS!!!

OK, here's mine. '84 Laser XE Turbo. Has MINT red checkerboard interior(save for the one tear on the passenger's seat...dunno what to do about it), power EVERYTHING, digital EVERYTHING. It needs an engine rebuild right now. :(
Tag reads: 84 TURBO :thumb:

I tried firing up the 84 Laser today after 23 years. Got spark, cranks over good and I hear power to the fuel pump...full tank of gas....NEW TANK...BUT...the pump is not sending fuel to the filter which is in line and when I take off the inlet line on the filter no fuel has made it from the tank. Is the pump bad(brand new Spectra Premium, Mopar sending unit) or something else? Would a bad relay prevent the pump from "pumping" Any ideas is greatly appreciated,,,,cheers...PAUL Also,,,,,I put a new oil pan gasket on and when I turn the motor over the crank is hitting the pan...all screws lined up just fine....can't figure that one out!! Sorry for posting here but can't find where to log in or post just this question....hmmm.
 

·
Registered
Joined
·
42 Posts
I figured I would make this thread... it seems We as Chrysler Laser Owners are kind of Forgotten and not to many threads or picutres of Chrsyler Lasers are Here so post up The Pictures of your Chrysler Laser (not the plymouth laser) So lets see what you got :) I will post up pictures of mine when I get them out of the camera:cool:
I tried firing up the 84 Laser today after 23 years. Got spark, cranks over good and I hear power to the fuel pump...full tank of gas....NEW TANK...BUT...the pump is not sending fuel to the filter which is in line and when I take off the inlet line on the filter no fuel has made it from the tank. Is the pump bad(brand new Spectra Premium, Mopar sending unit) or something else? Would a bad relay prevent the pump from "pumping" Any ideas is greatly appreciated,,,,cheers...PAUL Also,,,,,I put a new oil pan gasket on and when I turn the motor over the crank is hitting the pan...all screws lined up just fine....can't figure that one out!! Sorry for posting here but can't find where to log in or post just this question....hmmm.
271223
 

·
Registered
Joined
·
42 Posts
Hi y'all….I have an '84 XE Turbo I'm restoring (Gunmetal Blue) checkerboard seats etc but need a left front quarter piece of moulding that contains the side light. Any help would be much appreciated. Still a long way to go but it WILL be back on the road after setting for 23 years in my garage. Thanks...PAUL in TX
271266
 
501 - 504 of 504 Posts
Top